Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Filter Results’ Macro does not work for custom fields

Issue

- the Filter Results’ Macro cannot show custom fields

 

To reproduce

1. Create a Jira filter which contains both standard and custom fields

2. In Confluence select and add the Filter Results Gadget URL macro

On the macro

3. Set saved filter to that created in (1)

4. Set width to auto, number of results to 50 and refresh to 15 mins

5. In fields to display select and add some standard fields 

6. Click Save

7. The preview will display results (good)

8. Now add a customer field to the Fields to Display

9. Click Save

 

Bug

1. The preview does not display any results

 

Expected Result

1. The preview should display results when custom fields are selected to be displayed

 

Question

1. How do I show custom fields via the Filter Results macro?

 

2 answers

0 votes

Hello Mike,

Thank you for reaching out to Atlassian Community!

Just for a better understanding of the issue, I would like to know if it happens with any custom fields (that are not system fields) or if it's with specific fields from specific types.

I'm asking because I found two bugs related to the Filter result macro, so I want to make sure if it's related to the ones below or if maybe it's a new one:

Please, take your time to read the details of the bug tickets above and let us know if it's related.

If it's not, please, share with us the details I asked for at the beginning of this answer. 

Regards,
Angélica

Hi Angelica ... 

Thanks for following up; in response to your comments

- this issue happens with any custom fields

-  it is not the same issue as https://jira.atlassian.com/browse/CONFCLOUD-71298 which talks about an intermittent issue'; my issue happens every time I select a custom field

- its not the same as https://jira.atlassian.com/browse/CONFCLOUD-70878; I can see all fields to be added (including custom fields) and I can add the custom fields. 

My issue is once the custom field/s are added and I click the Save button under the Refresh Interval nothing happens - I don't see a preview

Hello Mike,

Thank you for the details.

I was able to replicate this behavior by selecting some random fields. I couldn't save and some errors appear on the console.

Screen Shot 2021-01-28 at 10.41.13.png

Can you please let the developer tools opened on your browser and then follow the steps again to check if some error will appear after you click on Save? Please, share a screenshot of the errors or warnings with us. Just make sure to hide private information.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS
Community showcase
Published in Confluence

Announcing Team Calendars in Confluence Data Center

Hi Community! We're thrilled to share that Team Calendars for Confluence is now a built-in feature for Confluence Data Center releases 7.11 and beyond.  A long time favorite,  Team Cale...

26 views 0 2
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you