Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Failure Updating App

Whilst upgrading the SSO for Atlassian Data Center from 4.2.17 to 4.2.20 on Confluence 8.0.2, an error occurred. The error has resulted in Confluence being completely in-operable and displaying in plain text.

It reports Logo System Error and the diagnostic below.

Filter execution threw an exception


I have restarted Confluence and the host server to no avail.

Has anybody got any ideas?

5 answers

1 accepted

0 votes
Answer accepted
Shekhar Gupta
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Jan 13, 2023

We have log the issue as a bug in our public issue tracking system. Please see the following issue to keep track of this problem - we have shared the details on below bug ticket:

Thanks @AAMIR ANSARI that worked for me!  I am not going to even bother reinstalling that app as I don't need it on server, using an alternate SSO method.

Exact same issue on our site as well. Downgrading plugin resolved it.

Unfortunately, I can't downgrade because I can't access the Manage apps section of Confluence anymore.

Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Jan 13, 2023

@togo I do not have access to the Atlassian Ticket. If you can paste the snippet of the error you are getting, I can check the plugin name and suggest some options.

2023-01-13 08:08:38,954 INFO [http-nio-8090-exec-6] [atlassian.confluence.status.SystemErrorInformationLogger] writeToLog
Request Unique ID : e6f5aa5b-3113-4e5c-812d-f4b8821de7ed
JVM Stats
xmx = 2147483648
usedNonHeap = 559636632
availableHeap = 1174481376
availableNonHeap = -1
allocatedHeap = 2147483648
freeAllocatedHeap = 1174481376
maxNonHeap = -1
availablePermGen = 0
maxPermGen = -1
maxHeap = 2147483648
usedHeap = 973002272
usedPermGen = -1
xms = 2147483648
Request Information
Scheme: https
Port: 443
URI: /confluence/500page.jsp
Context Path: /confluence
Servlet Path: /500page.jsp
Path Info: null
Query String: targetStatus=current
javax.servlet.forward.request_uri: /confluence/rest/experimental/relation/touched/from/user/current/to/content/214401903
javax.servlet.forward.context_path: /confluence
javax.servlet.forward.servlet_path: /rest
javax.servlet.forward.path_info: /experimental/relation/touched/from/user/current/to/content/214401903
javax.servlet.forward.query_string: targetStatus=current
javax.servlet.forward.mapping: org.apache.catalina.core.ApplicationMapping$MappingImpl@28b89
__prepare_recursion_counter: 1
javax.servlet.error.status_code: 500
struts.actionMapping: noActionMapping
brave.SpanCustomizer: SpanCustomizer(RealSpan(6aca5b739d1cbee1/6aca5b739d1cbee1))
com.atlassian.confluence.impl.profiling.DecoratorTimings: com.atlassian.confluence.impl.profiling.DecoratorTimings@5156fc72
org.apache.struts2.dispatcher.filter.StrutsPrepareFilter.REQUEST_EXCLUDED_FROM_ACTION_MAPPING: false
com.opensymphony.sitemesh.APPLIED_ONCE: true
javax.servlet.error.servlet_name: noop
brave.propagation.TraceContext: 6aca5b739d1cbee1/6aca5b739d1cbee1
__wrap_recursion_counter: 1
com.atlassian.confluence.web.filter.validateparam.RequestParamValidationFilter_already_filtered: true
atlassian.core.seraph.original.url: /500page.jsp?targetStatus=current
brave.servlet.TracingFilter$SendHandled: true
com.atlassian.gzipfilter.GzipFilter_already_filtered: true
B3-TraceId: 72ab2760c075f5
loginfilter.already.filtered: true
javax.servlet.error.request_uri: /confluence/rest/experimental/relation/touched/from/user/current/to/content/214401903
com.atlassian.core.filters.HeaderSanitisingFilter_already_filtered: true
com.atlassian.prettyurls.filter.PrettyUrlsSiteMeshFixupFilter: true
javax.servlet.error.exception: javax.servlet.ServletException: Filter execution threw an exception
os_securityfilter_already_filtered: true
com.atlassian.prettyurls.filter.PrettyUrlsSiteMeshFilter: true
targetStatus : current
caused by: javax.servlet.ServletException: Filter execution threw an exception
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(
caused by: java.lang.NoClassDefFoundError: com/opensymphony/xwork/config/ConfigurationManager
at com.atlassian.plugins.authentication.impl.web.filter.authentication.ConfluenceAuthenticationFilter.shouldFilter(

2023-01-13 08:08:38,954 INFO [http-nio-8090-exec-19] [atlassian.confluence.status.SystemErrorInformationLogger] writeToLog
Request Unique ID : ca848014-d2de-41af-be80-8699a6d791fe
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Jan 13, 2023


Looks like there is some issue with the authentication plugin

caused by: java.lang.NoClassDefFoundError: com/opensymphony/xwork/config/ConfigurationManager

at com.atlassian.plugins.authentication.impl.web.filter.authentication.ConfluenceAuthenticationFilter.shouldFilter(

I would suggest trying to delete the line which contains : com.atlassian.plugins.authentication.atlassian-authentication-plugin in table PLUGINDATA and then start confluence. 

Backup your database and run the below query:

delete from plugindata where pluginkey = 'com.atlassian.plugins.authentication.atlassian-authentication-plugin'; 

Then start the confluence again.

Let me know how it goes.

@John Appleton  : you need to connect to the Confluence database as documented in

In particular, use 

to locate the plugin, then 


To remove it. Then restart Confluence, and re-upload the previous plugin, which you have previously downloaded from (make sure to select the correct edition, and version -- in my case its DataCenter & 4.2.17)

@AAMIR ANSARI : yes, that's what I did. But the problem is that that plugin's latest version is causing this problem.

Like John Appleton likes this

@togo Thanks for that, I'll have a go at that. I was on that version before also.

@togo That Worked perfectly, I now have a fully functioning Confluence server again. Thanks for the steer on this, much appreciated.

0 votes
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Jan 12, 2023

@John Appleton 

Could you please share the error snippet from the logs after you are attempting to restart the confluence?



I am experiencing the same thing when I upgraded the same app today, it made Confluence completely unusable.

Es tut mir leid zu hören, dass du Probleme mit der aktualisierten App hast. Um das Problem zu beheben, gibt es einige mögliche Lösungsansätze, die du ausprobieren kannst:


1. Überprüfe, ob es bekannte Probleme oder Inkompatibilitäten mit der aktuellen Version der App gibt. Dies kannst du auf der Website des App-Entwicklers, in Support-Foren oder in der App-Beschreibung im App Store nachsehen.


2. Schaue, ob es möglicherweise eine Möglichkeit gibt, zur vorherigen Version der App zurückzukehren. Manche App-Stores bieten diese Option an, wenn eine Aktualisierung Probleme verursacht. Dadurch könntest du vorübergehend auf die ältere Version zurückgehen, bis das Problem behoben ist.


3. Wende dich an den Kundensupport der App. Sie können dir möglicherweise weiterhelfen, indem sie das Problem analysieren und dir eine Lösung anbieten.


4. Wenn das Problem dringend ist und die App unbrauchbar ist, könntest du in Betracht ziehen, die App ganz zu deinstallieren und erneut zu installieren. Beachte jedoch, dass dadurch möglicherweise gespeicherte Daten oder Einstellungen verloren gehen können. Sichere daher vorher wichtige Daten, falls möglich.


5. Wenn keine der oben genannten Optionen funktioniert, kannst du auch die Möglichkeit in Betracht ziehen, auf eine alternative App umzusteigen, die ähnliche Funktionen bietet.


Es ist wichtig, dass du auch Feedback zum Entwickler der App gibst, um das Problem zu melden. Dies kann dazu beitragen, dass das Problem schneller behoben wird und anderen Benutzern hilft.


Ich hoffe, dass dir diese Tipps bei der Lösung des Problems helfen. Wenn du weitere Fragen hast, stehe ich gerne zur Verfügung!

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events