It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Failed to upload PDF files

I was trying to upload files to a File List, .XLSX files were uploaded without problem, however, whenever I try to upload .PDF files, it always failed.

Error message: Invalid response received from the server.

4 answers

1 accepted

0 votes
Answer accepted
Adam Brokes Atlassian Team Apr 19, 2018

Hi Alex,

I've tried to reproduce this on Confluence 6.9 and in Confluence Cloud with several different PDF files but I wasn't able to see the error that you got in your instance. I was able to upload the files without any issues and display them afterward. Can you please provide additional information?

Did you follow this documentation: Cloud documentation or Server documentation?

What is your Confluence platform/version and what is the size of the files you are trying to upload?

Thank you,

Adam

Hi Alex, you may also want to check if the problem has anything to do with the size limits the instance administrator may have configured for attachment uploads.

Also, if this is a Server instance, the admin would be able to see what other messages are logged in the log file when you try to upload the PDF.

Cheers,

Renan

OK, thanks for the hint.

I found out the file size limit is from nginx which is sitting in front of Confluence.

It works now.

0 votes
Sarah Atlassian Team Apr 19, 2018

Hi Alex,

 

Can you provide some information on what version of Confluence you are using? Is it Confluence Cloud or Confluence Server? Where does the error occur on the page?

 

Cheers,

Ben

I found out it's a size limit problem with nginx which is sitting in front of Confluence.

Confluence version is 6.8.1

 

As I've checked the setting, which is the default value:

Attachment Settings

Attachment Maximum Size: 100.00 MB

Allows you to set the maximum size for each attachment uploaded to the site.

Maximum Attachments per Upload: 5

If behind an NGINX proxy server

In the configuration file in /etc/nginx/sites-enabled directory for the appropriate config file in the server section, add or update the client_max_body_size directive using an appropriate maximum size such as 100M to limit uploads to a maximum size of 100 Megabytes. The default when not explicitly specified is 1M

client_max_body_size 100M

server { 
listen 443 ssl;
server_name your_site.net;
client_max_body_size 100M;

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

Lessons and Learnings: Six Months of Working Remote [Discussion]

Hey there, folks! For most of us, the past six months- yes, you read that right- have been a journey. More people than ever before have pivoted to working remotely, and navigating being on-scre...

8,195 views 6 6
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you