Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,464,103
Community Members
 
Community Events
176
Community Groups

Export to PDF not possible with Safari

Hello,

In MacOS Ventura we noticed that the PDF Export is not possible in the Safari browser. In other browsers, exporting works. We tried pages with usual content (text and images) and also blank pages.

It might have not been working for longer, but the Safari version we are using right now is: Version 16.1 (18614.2.9.1.12)

After hitting export, it just shows the URL that is supposed to be opened, it looks like this:

https:/ourcompany.atlassian.net/wiki/spaces/flyingpdf/pdfpageexport.action?pageId=3646343436&atl_token=15j5v0535vv5n35vv53n530v5n393v53n0

If you manually open this URL, it says:


The following error(s) occurred:

  • Your session has expired. You may need to re-submit the form or reload the page.

 

Please reload the page you were trying to export and try again.

 

Best Regards

1 answer

1 accepted

0 votes
Answer accepted

Hi @mb 

This is a new and known issue. More on this thread: https://community.atlassian.com/t5/Confluence-questions/Re-Hi-this-also-affects-my-cloud-instance-so-it-seems/qaq-p/2202547/comment-id/258867#M258867

But Atlassian has in progress this issue https://jira.atlassian.com/browse/CONFCLOUD-74930 which should fix your problem.

Hi @Alex Koxaras _Relational_ 

Thank you for the information.

It seems like a similar issue, but as I said it works in other browsers and it's not showing the session error unless you manually copy paste the presented URL into the URL bar.

So it might be a different issue.

Though I can confirm that exporting to Word is possible.

The users are presented this:

bug_export_pdf.png

I also tried this workaround and it did not resolve the issue:

For all users, manually going to https://<Confluence-name-placeholder>.atlassian.net/wiki/welcome, should prompt the welcome option or perform some sort of "refresh", setting the user's cookie.

Once this is done, go back to the page(s), refresh them/the browser, and try exporting again.

Best Regards

I found out that if you go to page information, this error appears:

error_security_token.png

It says security token was not present. Could this be a different problem to the one you mentioned @Alex Koxaras _Relational_?

I can't be sure. But both have similar errors: "Session expired" / "Security token not present". But this is something that Atlassian's engineers know better. You can either comment on the above mention issue, or raise a support request.

Like mb likes this

Hello @Alex Koxaras _Relational_ I checked again today and noticed the bug issue is closed. I can confirm that the export is working again in Safari.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events