Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,299,824
Community Members
 
Community Events
165
Community Groups

Export to PDF doesn't expand Expand Macro?

My understanding from the documentation is that exporting a page to PDF should result in any included Expand macros being printed to the PDF "expanded".  However, I am not seeing this behaviour - the PDF generated by the export has no representation of the Expand macro.

 

I exported the same page to Word and the content of the expand macro is visible, but I'd far prefer to use the PDF export because the output includes many of the other features ("status", "panels") and therefore looks more readable.

 

I've had a look to see whether this is a bug, but can't find anything.

I created a basic page containing two expand macros and exported it to both PDF and word.  The images below show the issue - the first image is the PDF...with no visibility of the expand content.  The second image is the Word file, which shows the content of the expand and the expand caption.

PDFExport.jpgWordExport.jpg

 

Am I missing something?  Or can I report this as a bug (and how do I do that!!!??)


Cheers,

 

Michelle

2 answers

I can't log a bug :(  I'm not a site admin / our corporate agreement is somehow preventing me from logging a bug.  But this is a REAL nuisance.

0 votes
Fabian Lim Community Leader Nov 10, 2021

Hi @Michelle Smith

To report a Bug, Customers with a commercial support license should raise a support case with Atlassian Support. They will work with you directly to collect the details Development needs and craft a detailed Bug report so it has the best opportunity to be fixed.

Other Customers should ask a question here on the Community site. When the nature of the problem is clear, an Atlassian will either raise a Support request for you or report the Bug at jira.atlassian.com

Thanks for the info :)  I'll leave this for a couple of days and see whether anyone can suggest where I'm going wrong.  I can't believe it is a bug....surely it would already have been reported.  I suspect I have something configured incorrectly somewhere...

Fabian Lim Community Leader Nov 10, 2021

For me it works well, when I use the UI expand macro. But I'm on Data Center.  

uiexpand.png

You may want to review the export settings here: https://support.atlassian.com/confluence-cloud/docs/customize-exports-to-pdf/

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

An update on Confluence Cloud customer feedback – June 2022

Hi everyone, We’re always looking at how to improve Confluence and customer feedback plays an important role in making sure we're investing in the areas that will bring the most value to the most c...

323 views 2 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you