Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Expand - functionality not working properly.

Yathisha N March 21, 2024

We have used a expand macro in the confluence page but it is not working properly.

Below is the page if we click on expand it's not getting expanded and in the other sections of the same page expand is working but it is not added as a expand macro.

There are Achor macro's in the page not sure that is causing the issue. Could you please do the need full, Thanks in advance.

 

Below attachment is the one which is not getting expanded.Screenshot 2024-03-21 173224.png

Below attachment is the one which is getting expanded.

Screenshot 2024-03-21 144105.png

1 answer

1 accepted

1 vote
Answer accepted
Laura Campbell _Seibert Media_
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
March 22, 2024

Hi @Yathisha N and welcome to Community!

Your second image seems to be taken from the edit mode of the page since we can see the anchor macro, but I'm not seeing an expand macro. Is this a crop of what is inside the expand macro?

Just to be clear, you say most of the sections you want to have in an expand macro are working correctly, yet they aren't in expand macros

Could you provide a screenshot from the edit mode of the page of the paragraph with the expand you say that is not working? That would be your first example for Danielle Young Bear.

And just in case this helps solve the problem, if you use headers for the text, Confluence automatically creates an anchor link for the header, so you do not need to necessarily add an additional anchor macro.

Yathisha N March 25, 2024

Hi @Laura Campbell _Seibert Media_ Thanks for your response.

This issue is from one of our user she says all the cases are working fine except  "Danielle Youngbear". E.g. when I try to click “questions, answers and explanations” for Danielle Youngbear nothing happens.

Below are the answers for your questions

1. The image includes header along with the inside content, Even we are wondered that it is not showing expand macro but still working fine.

2.Yes.

3.Below image is in edit mode which shows the Expand macro but yet did not work after we click on publish.

Screenshot 2024-03-25 121949.png

Laura Campbell _Seibert Media_
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
March 25, 2024

@Yathisha N I see that you are using the old page editor. Have you tried converting the page to the new editor? That may fix problems with macros. The ability to embed more things within a macro (like the Expand macro) has recently been improved to support more kinds of formatting, but this is only with the new editor.

As for the text displaying/"working" despite not having an expand macro, that's just the text displaying normally. If there is no expand macro, there cannot be and hide/display functionality while viewing the published page.

Like Yathisha N likes this
Yathisha N March 25, 2024

@Laura Campbell _Seibert Media_ Thank you so much for your time it's working.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
PREMIUM
PERMISSIONS LEVEL
Site Admin
TAGS
AUG Leaders

Atlassian Community Events