Error while updating Universal Plugin Manager from 2.7.8 to 2.7.9 in Confluence 4.3.3

UPM online update fail with error: "An error was encountered while updating the UPM. Please see the logs for more details."

Exception in thread "Spring executor 24" org.springframework.beans.factory.UnsatisfiedDependencyException: Error creating bean with name 'updateParametersFactory' defined in URL [bundle://156.0:0/META-INF/spring/atlassian-plugins-components.xml]: Unsatisfied dependency expressed through constructor argument with index 0 of type [com.atlassian.sal.api.pluginsettings.PluginSettingsFactory]: : Error loading class [com.atlassian.upm.selfupdate.async.SimpleAsyncTaskManager] for bean with name 'simpleAsyncTaskManager' defined in URL [bundle://156.0:0/META-INF/spring/atlassian-plugins-components.xml]: problem with class file or dependent class; nested exception is java.lang.NoClassDefFoundError: com.atlassian.upm.selfupdate.async.SimpleAsyncTaskManager not found from bundle [Atlassian Universal Plugin Manager Self-Update Plugin (com.atlassian.upm.atlassian-universal-plugin-manager-selfupdate-plugin)]; nested exception is org.springframework.beans.factory.CannotLoadBeanClassException: Error loading class [com.atlassian.upm.selfupdate.async.SimpleAsyncTaskManager] for bean with name 'simpleAsyncTaskManager' defined in URL [bundle://156.0:0/META-INF/spring/atlassian-plugins-components.xml]: problem with class file or dependent class; nested exception is java.lang.NoClassDefFoundError: com.atlassian.upm.selfupdate.async.SimpleAsyncTaskManager not found from bundle [Atlassian Universal Plugin Manager Self-Update Plugin (com.atlassian.upm.atlassian-universal-plugin-manager-selfupdate-plugin)]

12 answers

1 accepted

Accepted Answer
4 votes

i think this issue is not viewable public:

therefor the solution is this:

access your confluence host/admin/viewplugins.action and upload the plugin manually which you downloaded before from here

https://marketplace.atlassian.com/plugins/com.atlassian.upm.atlassian-universal-plugin-manager-plugin

based on this kb article

https://confluence.atlassian.com/display/UPM/Updating+the+Universal+Plugin+Manager#UpdatingtheUniversalPluginManager-UpdatingUPMbyfilereplacement

this works. but self-updateplugin stays disabled....

This seems to be a bug in the latest version of the UPM. More infor and a workaround in https://ecosystem.atlassian.net/browse/UPM-2960

2 votes
Ben Woskow Atlassian Team Dec 10, 2012

There is a bug in UPM 2.7.8 and 2.7.9 which causes the UPM update to fail. Please take a look at the following Knowledge Base article for a workaround.

https://confluence.atlassian.com/display/CONFKB/UPM+Self-Update+fails+when+updating+from+UPM+2.7.8+or+2.7.9+to+newer+versions

Cheers,
Ben

This has been fixed for UPM 2.7.10

Well...this is so unbelievably crappy.

A product that relies so heavily on plugins that cannot update its own plugin manager.

This is just another in a long line of flaky problems with the upgrade manager which is all the more difficult to swallow because the price of the product has just doubled :[

Surely some of those obscene profits can be diverted to getting this right...surely?

Davet, Atlassian has react admirably IMO. They provided a workaround within hours, and released a newer version that fixed the issue in a day !

Inconvenient, yes. Crappy ? I know this is the internet, but a little bit of perspective might be in order.

I'll refrain from commenting about the "obscene" profits, but please go have a look at the Atlassian license options. They've been giving away licenses to non-profit and educational organizations, offering $10 (!!) license packs, and supporting open source projects and products for years. Not sure where the obscenity is in that.

i had some problems with jira and UPM update form 2.7.8 to 2.7.9

i got rid of it by doing as follows..

1. i deleted the 2 relevant files from INSTALL_DIR/plugins/installed-plugins/

atlassian-universal-plugin-manager-plugin and something like "upm.selfupdate"

2. i restarted jira

3. i installed manually upm 2.7.9 -> finishes w/o problem

I face the same issue when trying to upgrade UPM 2.7.8 to 2.7.9 in Confluence 4.3.3. I tried removing the Plugin and also cleared the cache but I was not able to upgrade. Anyone an idea?

Hello There,

I would suggest you to check if the server base URL that you have configured in the general configuration is the same that you're accessing by the web browser. You can see how to configure the server base URL in the following article:

https://confluence.atlassian.com/display/DOC/Configuring+the+Server+Base+URL

And another test that I would like to suggest you would be to change your server base URL to "localhost:8090" (default) and then try to upgrade the UPM. Generally this kind of behaviour when upgrading the UPM is related with the base URL and if you still experience problems please feel free to raise a support ticket at our support.atlassian.com and we will be glad to take a look with you at this problem.

I hope this helps.

Cheers,

LJ.

on my test system the problem also appears. no bad server base url is set.

i assume some broken classes in upm-selfupdate cause this behaviour.

is upm 2.7.8 bundled with confluence 4.3.3 ?

No, UPM 2.7.8 is not bundled with Confluence 4.3.3. I installed it manually.

ok .. i just research my support issues where atlassian discribed how to reset UPM to the bundled version...

is see

./bundled-plugins/atlassian-universal-plugin-manager-plugin-2.0.6.jar

now i have to find out how to get confluence started using this version.

after find&delete 2.7.8 version files in several locations a restart will bring them back again....

so confused right now...i installed 2.7.9 w/o any error in my private installation just yesterday...

Hi Alex,

can you please post the workaround here. I logged in to the page but have not the permission to view.

Thanks

Will the issue be solved with the next version of the UPM ?

Uninstalling the self-update plugin and re-attempting the update to 2.7.10 did not solve the problem for me (from 2.7.8 on Jira 5.2.1) - still seeing the same java.lang.ClassNotFoundException: org.springframework.beans.factory.DisposableBean

Am I missing something ?

Ben - OK. By asking if the problem was solved, I meant to ask if the workaround would still need to be applied :)

Can you confirm that a fresh install of Jira, which is shipped with 2.7.6 afaict, will update to 2.7.10 seamlessly ?

Gregory. Read bens latest comment here https://ecosystem.atlassian.net/browse/UPM-2960 You should be able to install upm 2.7.10 from any other prior versions except from 2.7.9
Ben Woskow Atlassian Team Dec 11, 2012

Gregory,

Yes, that is correct. You only need to do this workaround if you are updating from 2.7.8/2.7.9 to something newer.

Updating from UPM 2.7.6 to 2.7.10 should be seamless.

Ben

Thanks Ben !

(C.Faysal, I can't update from 2.7.9, but I figure that's either a typo on your part, or bad timing between this and your Jira comment:))

Uhm...is it only me ? I can't update upm from 2.7.9 to 2.7.10. jira & confluence

Well Gregory, I admire your restraint in refusing to comment on the "obscene profits" ;)

I do not see [Atlassian] in your title but if you had been working with their products for any length of time you would be aware of the age before the so-called Universal Plugin Manager and the nightmare that was plugin management.

It is important to keep in mind that Atlassian's base products are very limited in functionality and rely so heavily on third-party plugins that there is now a thriving market providing these essential functions or should I be saying "add-ons" now.

This is a very cosy relationship which suites both Atlassian and the plugin/add-on writers at the expense of the customer. This expense is magnified greatly by the enormous administrative workload required to license and administer so many versions of so many products from so many suppliers and , in fact, quite often leads to the riculous situation where it is impossible to upgrade the base product and enjoy the latest benefits and features for which we pay so dearly because the plugin/add-on writer is sick, on holidays, moved or just cannot be bothered.

The UPM was finally introduced as a glaringly obvious missing component of this dysfunctional system and the latest fafoos are just another in a long line of issues with a poorly designed and resource starved mission-critical component. The "workaround within hours, and released a newer version that fixed the issue in a day"

reaction from Atlassian is an indication of this components importance and the corporate embarrassment at being seen as not capable of releasing stable software version. You could say that they react admirably everytime they release a dud version but I say - get it right the first time instead of rushing a bodgy bit of software to market. It is not as if they cannot afford not employ another bod or three to actually check that it works! This what I mean by crappy!

Which leads me on to your defensiveness about the Atlassian profits. When an already healthy profit level is further bolstered by a doubling of the price - because they can - then it becomes obscene! The market may bear it due to a lack of competition but it really does not engender loyalty - your good self excluded.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 09, 2018 in Confluence

Introducing Praecipio Consulting, an Atlassian Solution Partner

Hey there Community!  My name is Vannya Vallejo, the Channel Communication Specialist at Atlassian and I want to help Atlassian users like you learn about our Solution Partners and how they c...

369 views 0 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you