Error in migration from Cloud to Confluence Server

Manuel Calderón
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September 30, 2020

Following, I shows the error that appeared after install my export file .zip in the free 30 days trial.

Cause
org.apache.velocity.exception.MethodInvocationException: Invocation of method 'isShowSignUp' in class com.atlassian.confluence.user.actions.LoginAction threw exception java.lang.NullPointerException: Application cannot be null at /login.vm[line 6, column 28]
at org.apache.velocity.runtime.parser.node.ASTMethod.handleInvocationException(ASTMethod.java:342)

caused by: java.lang.NullPointerException: Application cannot be null
at com.google.common.base.Preconditions.checkNotNull(Preconditions.java:895)

1 answer

0 votes
Diego
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
October 5, 2020

Hello @Manuel Calderón !

This error could be related to the order in which your user directories are currently set. More specifically, how they are listed in your database. Usually means that no directory with the index of 0 exists.

You can check more details about it here:

Even though we have this document about the issue, I would like to ask you a few questions:

  1. What version of Confluence are you currently running?
  2. What is the operating system of your server?
  3. Was Confluence working before the Cloud import?

 

Let us hear from you!

Manuel Calderón
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
October 5, 2020

@Diegothanks for your reply!!

I answer your questions below:

  1. Confluence 7.4.4
  2. Windows 7 64 bits
  3. I would like to migrate from Cloud to Confluence server, but the thing is that I can't star the server before the Cloud import.

Before our answer, I was thinking that the problem could be that I don't have the required permissions to start running the server... is it a possible cause?

Thanks!!

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