Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Error after upgrade

Good day,

the following error is displayed after ugprade of Confluence:

Pre-upgrade validation failed. Check the Confluence application logs for more details. You'll need to fix these problems and restart Confluence before you can upgrade. Upgrade error message: Cannot update schema

1 answer

0 votes

You should do what it says and check what the application logs say to confirm exactly what went wrong.  Start with <confluence home>/log/atlassian-confluence.log

"Cannot update schema" though strongly suggests a problem with the database.  The application log will tell you the details of that, we can't tell you a lot more without the specfics from the log.  It might just be that there's a dodgy character in the data somewhere, but it's more likely to be a mis-configured database, and there's a chance that it might even be damaged.

I see these errors in the log:

2020-11-11 09:38:16,505 ERROR [Catalina-utility-1] [engine.jdbc.spi.SqlExceptionHelper] logExceptions The database name component of the object qualifier must be the name of the current database.
2020-11-11 09:38:16,505 ERROR [Catalina-utility-1] [atlassian.confluence.plugin.PluginFrameworkContextListener] launchUpgrades Upgrade failed, application will not start: com.atlassian.config.ConfigurationException: Cannot update schema

2020-11-11 09:38:16,520 ERROR [Catalina-utility-1] [atlassian.confluence.plugin.PluginFrameworkContextListener] launchUpgrades 1 errors were encountered during upgrade:
2020-11-11 09:38:16,520 ERROR [Catalina-utility-1] [atlassian.confluence.plugin.PluginFrameworkContextListener] launchUpgrades 1: Cannot update schema

Thank you

Daniel Ebers Community Leader Nov 13, 2020

Can you confirm you are using MS SQL as a database backend?
If so, the following article might be of interest for you:

https://confluence.atlassian.com/confkb/the-component-of-the-database-name-of-the-object-qualifier-must-be-the-name-of-the-current-database-error-on-upgrade-to-confluence-6-1+-902076143.html

It describes the background as well as possible fixes.

In case you are using a different database as backend please also let us know.

Thank you, after the upgrade the connection port to MS SQL has changed. Now everything works.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
7.9.0
TAGS
Community showcase
Published in Confluence

Announcing Team Calendars in Confluence Data Center

Hi Community! We're thrilled to share that Team Calendars for Confluence is now a built-in feature for Confluence Data Center releases 7.11 and beyond.  A long time favorite,  Team Cale...

26 views 0 2
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you