Enable SMTP configuration with SSL

Hello,

We want to setup our SMTP server in Confluence to send email. If I setup with port 25 it works like a charm. But we need to configure it through SSL with 465 port.

If I setup the port 465 I receive this error:

https://pastebin.com/LyvSYi8W

And we cannot select TLS option because our server is working with SSL instead of TLS.

¿How can we proceed with this environment?

Thank you very much

2 answers

This widget could not be displayed.
Daniel Eads Community Champion Aug 16, 2017

Hi,

SSL/TLS can be a bit confusing because the name changed even though they're doing the same things. TLS 1.0 would be SSL 3.1 if they'd kept the name instead of changing it.

Despite us saying "SSL certificate" or "SSL configuration", we generally mean TLS 1.0 or above because SSL2 and SSL3 are both proven to be very insecure now.

My advice is to select that TLS checkbox in the mail handler configuration in JIRA. Chances are that your mail server is actually set up with TLS 1.0 or better already. And if it's not, JIRA will try to use SSL2/SSL3 depending on what's configured on your mail server.

This widget could not be displayed.

Hello Daniel,

Thanks for your answer.

If I select the TLS checkbox I receive same error provided.

Thank you very much

Regards

Daniel Eads Community Champion Aug 16, 2017

Bummer! If your SMTP server is accessible from the internet (i.e. you can send email outside your office without having to connect to VPN), you can try using the tool at https://www.checktls.com/perl/live/TestReceiver.pl - you can just enter some dummy email address on your domain like "test":

 

image.pngLook for the TLS column (highlighted above). If it's not OK, you'll need to work with your mail server administrator to get it enabled. This varies depending on what mail server you're using and is outside something we're able to help you with here.

If it does say OK, check with your network team to see if there are any firewall rules in the way between your JIRA server and your mail server over that port. It's also worth checking to make sure the mail server has a signed certificate from some place like Comodo, GeoTrust, or DigiCert. Self-signed certificates might cause a problem. If you're using Java 7, ther are also a few certificate providers like GoDaddy that require some extra configuration to be accepted by Java.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

409 views 4 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you