Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Empty Task Report & Table Transformer

I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
Apr 05, 2023


I'm having problems getting multiple task reports working in one table transformer. Since each task report ist limited to 40 entries and only can display one assignee, I tried to limit entries by creating one task report for all incomplete tasks for each subpage. With this workaround I can list all tasks for the team and do the needed filtering with the table transformer, which is wrapped around all task reports. 

Now with this rather clunky workaround I face another problem, which I haven't found a solution yet. If one of those multiple task reports is empty the whole table transformer runs into an error. It seems like an empty task report is returning nothing, instead of an empty table. Trying to fix this issue with the sql command, e.g. for Table 1 "if not exists(select * from T1)" returns a typeerror. So the sql-usage seems to be limited. 

Is there a way to solve this issue? An empty task report has to return something at least, as it shows "No incomplete tasks" when used without the table tansformer.

Thanks for your help!

1 answer

1 accepted

4 votes
Answer accepted
Katerina Rudkovskaya _Stiltsoft_
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Apr 05, 2023

Hi @codadevbu,

Not sure what your current SQL query looks like but here are some hints for you: as your Task Reports have the same headers, you may merge them using the standard “Merge” preset via the Table Transformer macro. The SQL query that stands behind this preset is “SELECT * FROM T*”, so we don’t call any specific tables (T1, T2, T3, etc.) and it is not important how many tables we have.

Then you go to the Table Transformer macro settings -> Options tab -> Source data: Hide all content. Here we get rid from the information blocks that appear if there are no any suitable tasks for the specific Task Report.

So, as a result, you’ll get one combined table.

To filter and/or transform it further, you may use another Table Transformer or Table Filter macro on top of the first Table Transformer macro.

Hope this workaround helps your case.

By the way, you may also browse the Atlassian Marketplace and find some apps that will enhance your experience with tasks and reports.

For example, our company also develops the Handy Macros for Confluence app – you may check its Handy Tasks feature.

I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
Apr 17, 2023

Thanks @Katerina Rudkovskaya _Stiltsoft_


that solved the problem. I thought I have to union all tables, but this way it's way easier.

Like # people like this

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events