It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Edit button is missing from selected pages even though my permissions are ok

My permissions are set to 'can edit' but I don't see an 'edit' button. Only on certain pages.

2 answers

1 accepted

0 votes
Answer accepted
Dominic Lagger Community Leader Feb 12, 2020

Hi @Barak_Epstein 

I think the problem is, that you don't have write permission on the space.

The restrictions on a page can not overrule the space permissions.

Check out the documentation for space permissions.

Regards,

Dominic 

@Dominic Lagger this makes sense. I will look into it!

@Dominic Lagger  You were precisely correct. Problem solved, and thanks!

Like Dominic Lagger likes this

this is awful! you need to give everyone in the company permission to add/delete any pages you like to a site just so they can edit one specific page???

talk about a majorly broken permissions model. especially since the default for all pages is to have no restrictions... i had to give my users access to edit the entire space. sucks but solved the problem.

 

"The restrictions on a page can not overrule the space permissions."

 

incredibly stupid design. consider revising. Permissions should not be default allow, they should be default restricted.

0 votes

Hello @Barak_Epstein ,

seems there are some page restrictions set for these specific pages. Check out this documentation about restrictions on pages, maybe that is the case: https://confluence.atlassian.com/doc/page-restrictions-139414.html

Let me know if that helped.

Adam

Hi @Adam Rypel _MoroSystems_ , I see 'can edit' besides my name when I open up restrictions.

Not sure if I'm missing anything else.

Thanks,

Barak

Okay, that is strange.

If you try different browser, is the button there? Also which Confluence version are you on?

Lastly, if you set the restrictions of page to "No restrictions", does that help?

Adam

I've tried on multiple browsers.

 

I'm not the Admin so can't set to 'no restrictions.' I could ask, potentially.

 

BE

Pages can be restricted to certain users even if users attempting to access the page have edit permissions in the space. To view the “edit” button on a page you must have edit permissions for that page if it has additional restrictions. To confirm access you can try to view the Page Information to view restrictions for those pages. See: https://confluence.atlassian.com/doc/view-page-information-139408.html

Thanks, Tiffany!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

Lessons and Learnings: Six Months of Working Remote [Discussion]

Hey there, folks! For most of us, the past six months- yes, you read that right- have been a journey. More people than ever before have pivoted to working remotely, and navigating being on-scre...

8,411 views 6 6
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you