Drag and Dropped Images only show for the Author, broken for all other users

I posted a question yesterday but after further investigation I narrowed it down to a drag and drop issue so I'd like to post this as a separate question and I'll look at closing the other one.

I'm using Confluence 5.7 on my Windows Server 2012 R2 setup as I've been running over a year.  This issue has been occurring for a few releases now, it's not a 5.7 specific issue I believe.  It is not specific to a browser or operating system as some of my users use Mac and others Windows.  I can duplicate this with my Mac using Safari though, if that matters.

Create a new blank page and drag and drop a PNG image into it.  Save the page, it shows fine.  I can check from other computers and as long as I'm logged in as me the image will appear.  If I login as a test user (member of only jira-users) (and yes, I'm using JIRA for user management) I see a broken image.  If I click the paper clip at the top I see the attachments listed, if I click it I get an error message.  Images are stored in the file system since storing in the database is now deprecated, we used the database before, same problem.

I've been over the installation notes over and over, checked permissions, etc.  I'm not sure what to check or how to fix or if this is purely a bug in confluence.  I was thinking maybe IUSR needs write permission because it's Windows but then I thought no, that's IIS and this is not running under IIS.

We prefer drag and drop images but the only thing that works properly is to use the INSERT toolbar option, then it works correctly.

Thank you.

4 answers

1 accepted

Thank you Atlassian Support.  After extensive work to figure this out they determined it was the "Tracking Plug-in" that was a conflict.  After uninstalling this plug-in, which I never used, everything works like it is supposed to.

Neal, Thanks for posting this; I've noticed the same thing but haven't made the time to explore it further. This page from Atlassian's documentation, Using Drag-and-Drop in Confluence at https://confluence.atlassian.com/display/CONF55/Using+Drag-and-Drop+in+Confluence, offers some insights into older browsers and specific Confluence theme's that don't support drag-and-drop, but there's no mention of the 'I see it in my browser, but others don't see it in theirs' issue.

Thanks for the link. We're all using the latest browsers and the site is using the default theme. One of the error messages I received from the test user was to reset the theme, not sure if something underlying is messed up. I once tried the refined wiki and uninstalled it, not sure it completely reverted things but that may not be the issue. Long story longer, I disabled Drag and Drop as outlined in your suggested link which is the safest bet to just ensure no one can use it and this issue will no longer be a problem for us. Drag and Drop is nice but it's just not working for us at this time. Thanks again.

Good idea to uninstall for now. Maybe someone else can chime in with further insights on this.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

2,779 views 26 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you