Documentation Theme: Global CSS (in external file)

Hi,

I would like to have two global CSS files in Confluence. I read the post "How do I override css / styles in the documentation theme?", but it did not help me so far.

I would like to have:

  • One stylesheet for the Dashboard and all themes, including specifications for header and fonts.
  • One stylesheet for the Documentation theme with special stuff.

I tried to import the stylesheet via Admin Panel > Administration > Look and Feel > Custom HTML > At end of the HEAD.

<link rel="stylesheet" type="text/css" href="http://my.confluence.url.com/download/attachments/14073389/confluence.css" />

But that does not work in spaces, which are using the documentation theme, even if I specify the ID at the body element:

body#com-atlassian-confluence.theme-documentation

The CSS does only work, if I use it in a space stylesheet via My Space > Space Administration > Space Stylesheet.

I'd appreciate any kind of help.

Thank you very much and best regards!

Stefan

5 answers

1 accepted

1 vote
Accepted answer

Hello Stefan,

I mocked this up in my own instance and it seems to be working alright. If you past the link to your stylesheet in another window are you presented with the css that you expect?

You also may want to try uploading the stylesheet to a third party host. This would ensure there is no confounding factor of the content ID of the attachment being changed and you linking to an old version of the document.

If you have physical access to the machine and are running on our standalone version of Confluence the webroot is the <confluence_install>/confluence directory. You could make a css folder here and link to your stylesheet that way.

Hi Daniel,

thanks for your reply.

If you past the link to your stylesheet in another window are you presented with the css that you expect?

No, Confluence tried to download the file, instead of rendering it. I found the error. The CSS had the wrong content type.

I had to change it from application/x-upload-data to text/css. Now it works!

BEFORE


AFTER



Stefan,

Excellent catch! Sounds like you have a good handle on how this fix works.

Enjoy your upvotes!

Hi Daniel,

thanks! Unfortunately the content-type switches back to application/x-upload-data, if I upload the file again. That does not make sense to me, because the object should have a content-type and not its version.

There is another stylesheet in the header after my own. Maybe this stylesheet overrules mine.

Strange, removing the last two stylesheets did not help. Firebug tells be, that my resource is not text...

You can also post external style sheets using regular confluence markup. Not sure if you've tried this in the documentation theme's customation menu.

Wiki Markup would be:

{style:import=url}{style}

I haven't had any issues attaching an external .css file with this method.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Organizing your space just got easier - Page Tree Drag & Drop is here

Hi Community! I’m Elaine, Confluence Product Manager. You may have read my earlier post about page tree in space navigation sidebar. I'm excited to share another improvement that helps you organize ...

110 views 3 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you