Disable email notification permently in confluence

Hi Guys,

Could you please let me know how I can disable email notifcation permently in confluence? Is the same way we are doing it in the JIRA? like

set JAVA_OPTS="-Datlassian.mail.senddisabled=true -Datlassian.mail.fetchdisabled=true"
Or, is this required while doing the confluence restore from XML backup?
Thanks

3 answers

Could you please rexplain correctly...

I have added below content to setenv.bat file,

-Datlassian.mail.senddisabled=true -Datlassian.mail.fetchdisabled=true

in the set JAVA_OPTS=%JAVA_OPTS% section. But I dont find any difference in confluence (IN JIRA we can see that sendmail disabled from mail queue page) and also not refecting this paramters in the JAVA Runtime arguments section in the system information page.

We are having confluence standalone installations... and version is 4.3.7

Please help.

I guess you can try delete the mail server manually, basically remove the reference to the SMTP server, in this way will disable email notifications for all users.

I'm trying to restore production data on to my dev server by XML restore option. So in that case if we remove mail server details from dev server and perform the restore option, then also the mails will get generated while restoing the date, becasue XML file contains production mail server details.

So in the above scenario, I guess the only option is available to block the mail is disabling mail server at startup level..

For that I'm trying to put JVM parameters to setenv.bat file, but after service restart its not reflecting anything and mails are sending smoothly.

Now I got the issue that, our confluence is insatlled as service in windows server. So I have to perform either command line option or windows registery option to put the JVM arguments, as mentioned in the below link,

https://confluence.atlassian.com/display/JIRA/Setting+Properties+and+Options+on+Startup#SettingPropertiesandOptionsonStartup-WindowsService

Trying this option and will update the progress here.

Thanks,

Sanu P Soman

Hi Sanu,

Initially would be just "atlassian.mail.senddisabled" = true, but may I ask you if you're running Confluence as a service? And if so, did you try to re-create the service and try to start Confluence by the .bat or .sh file and see if the changes were applied?

Kind Regards,

LJ.

Yes. our Confluence is running as service.

Re-createing confluence service will solve the issue? If so, could you please help me on this? Is something like below?

In command line,

net stop <current service name>

service.bat remove <current service name>

service.bat install <new service name>

net start <new service name>

In which file I need to put the JVM arguments, service.bat or setenv.bat?

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Tuesday in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

407 views 17 9
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you