Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Disable automatic numbering?

We have a template in use with 2 columns and multiple rows. The rows on the left-hand column each contain a procedural step. If there is a corresponding graphic to go with a step, it is inserted in the adjacent right-hand column.

Since these are steps, we like to number them. Since each is in it's own section, the numbered list markup wont work, and numbers each as "1.".

If I manually number the first row, automatic numbering reformats it. If I then move to the next row and manually number and indent the entry, it does not reformat, and subsequently doesn't quite match the first row. The indent is different between the two.

There is no apparent way to disable the automatic numbering that occurs in Row 1. If I deselect the markup, it removes the number and indent. Further attempts to re-add the number result in automatic numbering again.

Is it truly all-or-nothing, or is there a hidden trick to disable this behavior?

2 answers

2 accepted

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

Post a new question

Hello everyone!

Thank you for following up on this question. In this example from 2019, Darryl was using the legacy editor. I can confirm that disabling autoformatting in Confluence Cloud will only disable automatic numbering in pages using the Legacy editor.

For the new editor, it's not possible to disable the automatic numbering. We logged a feature request for this below:

Please add your vote to the case so we can prioritize this accordingly!

Thank you all, and take care!

Shannon

0 votes
Answer accepted
Shannon Atlassian Team Aug 20, 2019

Hello Darryl,

Happy to help you with this. I'm trying to replicate this behavior on my own instance, but the numbering doesn't autoformat unless I use the numbered list option. I've tried this in a table as well but it does not auto-format for me.

Would you be able to show us an example of what you're talking about? You could create a test page in Confluence and record the behavior with something like screencast-o-matic.com and share it here.

Regards,

Shannon

Hi Shannon,

Thanks for your reply. I will look at capturing the live behavior, but thought I'd share a screenshot displaying the behavior in the meantime:

2019-08-20_07-27-16.png

As shown, the first section is achieved by typing "1.space" (number one, period, spacebar). This automatically sets the format to numbered list, which is a common behavior in word processors. You can see that the number and the period are offset and the text is all indented the same.

The second section is the same process except using 2 instead of 1. It does NOT set the format to numbered list, and does not indent the text or offset the number from the text.

Darryl

Like Nancy Bonanno likes this
Shannon Atlassian Team Aug 21, 2019

Darryl,

To do it on the fly, you can hold down the option key before you hit the space button, and it won't apply the autoformatting. I just tried this on my Mac and it worked. I don't know about the same on Windows.

The setting to disable Autoformatting altogether is in your personal settings menu. Click your avatar in the bottom left-hand corner, and click Settings. From here, under Your Settings click Editor. There you will find the option that says Disable Autoformatting. When you disable that, Confluence will no longer autoformat anything.

I hope that helps. Let me know if you have any questions.

Regards,

Shannon

Shannon,

Thanks so much for the info! I honestly never would have thought to look in Settings, as I relate it primarily to personal/Profile and frankly don't have much occasion to go in there.

Darryl

Like Shannon likes this
Shannon Atlassian Team Aug 22, 2019

You're welcome, Darryl. Happy to help!

Regards,

Shannon

disable auto formating in settings does not work!

And it's gone. As of this post, there is no option there to disable this intrusive idiotic nonsense.

TAGS
Community showcase
Published in Confluence

Confluence Mythbusters: Does Atlassian even use Confluence?

Hi, Confluence collaborators! As part of #Confluence-Collaboratory month, we’ve created a very special Mythsbusters segment, where we're dive into an interesting myth and uncover the truth behind i...

1,517 views 7 29
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you