Disable Public Access to Confluence

Hi,

I've disabled public access to confluence by revoking Use Confluence permission to Anonymous Users in Global Permissions

But on the sign-in window users still see a message "No username and password? Sign up here" which takes them to a sign-up form, although pressing the "sign up" button at the end doesn't do anything.

Is there a way to disable this form - we shouldn't be saying "sign-up here" if they can't

thanks,

Mark.

5 answers

1 accepted

This widget could not be displayed.

Your welcome Mark,

I modified my previous answer style.

I think you can refer to "Adding and Inviting User". They briefly explain how to allow people to signup. You can use this documentation based on your need.

Let me know if you have any other questions.

Cheers,

Saleh

Excellent - thanks. The User Signup Options tab was exactly what I was after. Funny, I hadn't noticed it before.

Thanks.

This widget could not be displayed.

To enable or disable public signup:

  1. ChooseBrowse>Confluence Admin.
  2. SelectSecurity Configurationin the left-hand panel.
  3. ClickEdit.
  4. Tick thePublic Signupcheckbox to enable public signup. Clear the checkbox to disable public signup.
  5. ClickSave.

check the following doc

https://confluence.atlassian.com/display/CONF41/Enabling+or+Disabling+Public+Signup

This widget could not be displayed.

Hi,


Thanks for your response. I had already read that article, but in my Edit Security Configuration screen there is no checkbox for "Public Signup".

I assumed the documentation was out of date? Else why am I not seeing this? (see attached screenshot)

thanks,
Mark.

This widget could not be displayed.

Hi,


Thanks for your response. I had already read that article, but in my Edit Security Configuration screen there is no checkbox for "Public Signup".

I assumed the documentation was out of date? Else why am I not seeing this? (see attached screenshot)

thanks,
Mark.

what is the confluence version?

we're on 5.4.2

This widget could not be displayed.

Hi Mark,

To disable anonymous access to your site:

  1. Choose the cog icon at top right of the screen, then choose Confluence Admin.
  2. Choose Global Permissions in the left-hand panel.
  3. Choose Edit Permissions.
  4. In the 'Anonymous Access' section, deselect the check box to disable anonymous access to the content on your site.
  5. Chose Save All.

Note: You must grant the 'can use' permission as well, if you want to grant the 'View User Profiles' permission.

You can refer to this KB for more information

Cheers,

Saleh

Thanks, that's exactly what I've done (see my original question at the top of this thread).


But users still see the "No username and password? Sign up here" message on the login page which takes them to a sign-up form. Why is this still appearing?

I am also having this issue in Confluence 6.2.0.  Is there a way to remove this from the login screen?

 

Public access has been disabled.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

462 views 6 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you