Disable Notify Watchers in Confluence 5

Hi,

After upgrading to Confluence 5, this JS trick (from here) to disable notify Watchers in Confluence editor stopped working:

<script>
  AJS.toInit(function(){
    <!-- Disable "notifyWatchers" checkbox by default (on edit pages only) -->
    AJS.$('input#notifyWatchers').attr('checked', false);
  });
</script>

Any idea what changed in Confluence 5?

Thank you!

8 answers

1 accepted

This widget could not be displayed.

Just to note that the right way to do it in Confluence 5 is described in this KB:

https://confluence.atlassian.com/display/CONFKB/How+to+uncheck+Notify+watchers+check+box+on+Confluence+editor+by+default

This widget could not be displayed.

Hello Adolfo,

I just wanted to take the chance to push out the official Atlassian response to why we were not providing a global way to toggle off autowatchers.

https://jira.atlassian.com/browse/CONF-22070

The solution you point to above is also provided in this ticket. I also left a note in that issue stating that the hack around no longer works in Confluence and linked to this post.

Please add yourself as a watcher to that issue as an alternative source of information.

This widget could not be displayed.

Imagine the fire alarm went off everytime someone walked out the door. Eventually the entire office would be wearing headphones.

That's pretty much what defaulting "Notify Watchers" to a checked state has done.

This widget could not be displayed.

Hi, I wanted to add, that I would also like to have an opt-in routher an opt-out , as it is a noble and likely understanding that information is always ok , but if you are editing those confluence Page like you are doing it with your Word oder PPT , then you want to "save" frequently just because you know that there is no automatic saving ;(

I dont think that Im the only one who know what I mean , you just loose work !

But in saving it and forget to "remove" the button the guys at work hate you because of all the "Spam" you generate !

This widget could not be displayed.

@Daniel:

"The solution you point to above is also provided in this ticket": Where?

"I also left a note in that issue stating that the hack around no longer works in Confluence..."

I' abit confused...I could not get the script running in 5.1.1 It appears in html page head section but the checkbox is always checked.

Any advise?

This widget could not be displayed.

@Adolfo: THANKS!!! It works :)

Regards /Markus

Hi,

Any idea how to make Notify Watchers checbox disabled by default only for a particular space.

-Kapil

Kapil - look at the KB article linked above, in the comments someone added code that allows you to restrict what spaces the feature is unchecked by default in.

This widget could not be displayed.

It worked for me. Using 5.1

This widget could not be displayed.

I think that this should be added as a setting by Atlassian.

Usually you don't want this to take effect on all spaces. Sure you can set it per space, but just imagine how "structured" the Javascript code will be in Custom HTML if you need to set this for say 15+ spaces...

Like when you nest groups into each other or add users into groups, it should be possible to just add/remove spaces where Notify Watchers checkbox is disabled by default.

-Ramon

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

476 views 6 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you