Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,373
Community Members
 
Community Events
176
Community Groups

Disable Emoticons

Hi,

when we type :p in our Confluence 4.1 we get an Emoticon for it.

As shown here http://confluence.atlassian.com/display/CONF41/How+to+Disable+Emoticons it should be possible to escape. But this \:p does'nt work!?

Is it a bug? How to avoid the replace?

Thanks!

2 answers

1 accepted

2 votes
Answer accepted

Resolution: https://jira.atlassian.com/browse/CONF-24059

snip:

You don't need to escape the emoticons in Confluence any more.

If you want the plain text :) instead of the smiley then just click Undo (Ctrl+Z) after typing the characters to undo the autoconvert.

If you don't want autoconverting to happen at all, you can just disable it in your editor settings.

Great catch mate.....

Unfortunately it's even worse: Our version of JIRA does not do the conversion on the fly but when saving (and/or displaying) the text. I.e. while editing I see my text the way I have written it and when I save or update the issue I suddenly see emojis at odd places in my text! This is so brain-damaged!  

Hi Dirk,

Sorry, i have tried both mentioned option mentioned on this page:

http://confluence.atlassian.com/display/CONF41/How+to+Disable+Emoticons

But I am not able to disable emoticons on my local 4.2 instance which used the same editor as 4.1. Judging from the documentation, it seems that it only works on Confluence 2.9=3.5 which still use wiki markup technology.

Backslash ("\") feature as mentioned by the documentaiton work only on wiki markup editor, hence if you prefer to use this, you would need to use wiki markup plugin which is accessible from your insert macro option.

Hope it helps.

Cheers,
Septa Cahyadiputra

Hi Dirk,

Sorry forget to mentioned one important point. You would need to do the mentioned modification at wiki-renderer-components.xml as mentioned on the page http://confluence.atlassian.com/display/CONF41/How+to+Disable+Emoticons to make wiki markup took the "\" backslash feature.

Hope it helps.

Cheers,

Septa Cahyadiputra

Hi Septa,

is there a ticket to fix this behavior?

thanks!

Dirk

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events