It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Disable Confluence shortcut keys

Is there a way to do this please?

Right now when I view my docs and accidently press [ key, the left navigation panel disappears. It's a bit confusing to users.

Thanks

4 answers

3 votes

Hi MPal,

You do not need to modify the Jar file if you just want to disable a shortcut. To disable a shortcut do the following:

1 . Go to the admin console.

2. Select plugins.

3. Click on 'Show System Plugins'.

4. Search for the 'Confluence Keyboard Shortcuts Plugin' and expand it.

5. Click on 'Manage plugin modules' to see the individual modules

6. Each shortcut will have it's own module that can be disabled. The one you want is called 'Toggle Navigation Panel'

I'm sorry, you are right. I thought the page was a generic explanation, but it is really just a specific example.

To make the change you want:

  • The jar file to look for is /WEB-INF/classes/com/atlassian/confluence/setup/atlassian-bundled-plugins/confluence-keyboard-shortcuts.jar
  • The file you need within that jar is called atlassian-plugin.xml
  • It contains an element <keyboard-shortcut key="toggle.navigation.panel">
  • Either remove the entire element, or else change the shortcut to another key.
  • Follow the instructions to save these changes and restart Confluence.

Hope that is enough info - let me know if you need anything more.

Cheers,
Mark

Thank you Mark. This guide is to change ctrl+alt+q to ctrl+alt+y.

Not really specific on what I want to do. :(

I'm sorry, you are right. I thought the page was a generic explanation, but it is really just a specific example.

To make the change you want:

  • The jar file to look for is /WEB-INF/classes/com/atlassian/confluence/setup/atlassian-bundled-plugins/confluence-keyboard-shortcuts.jar
  • The file you need within that jar is called atlassian-plugin.xml
  • It contains an element <keyboard-shortcut key="toggle.navigation.panel">
  • Either remove the entire element, or else change the shortcut to another key.
  • Follow the instructions to save these changes and restart Confluence.

Hope that is enough info - let me know if you need anything more.

Cheers,
Mark

thanks Mark. This works well :)

Ideally, you guys should enable user to configure this through the UI

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Confluence

What's New in Confluence Cloud – November 2019 Edition

Hey community! This month we’re excited to share brand new features to help you make your mark on Confluence. If you haven’t already, check out our updates from October and September too! Expre...

30,052 views 29 57
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you