Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Detected tables with non-default collation. But which one it is?

Hello guys,

confluence was running fine on our server till I started the update to 5.2.5 today. Since then it doesn t start anymore, but greets me with with an error page, telling that one of the tables use non-default collation. I went forth and looked for it in phpmyadmin, but all tables I can see are utf8_bin and also all the fields in the tables are formated correctly.

Since the logs do not give further information, maybe somebody has an idea to track this down?

Thanks!

kind regards,
Daniel

2 answers

Well I actually answered this myself. It was not a collation problem at all. For some reason one of my tables did have different structure compared to a new Confluence installation. So I dumped the database from a new installation, structure only. Imported it and put my data in, everything was fine again.

Quite sad actually!

Could you further explain how you resolved the problem? I believe I'm having the exact same issue.

I'm in the process of upgrading MySQL from 5.1 to 5.7. While I was on 5.1 Confluence was working but I upgraded Confluence from 6.0 to 7.4 while on MySQL 5.1. Confluence worked fine pior to any changes.

I began the upgrade from MySQL 5.1 to 5.5. Backed up my databases, dumped the databases and uninstalled MySQL 5.1, installed MySQL 5.5 and imported my databases. All my other databases work fine other then confluence and I'm getting the error listed in this topic.

I tried to follow the MySQL recommended settings but nothing has made a difference. I dumped the database and created a new one. Tried importing structure only. Still had the issue, dumped the database and created a new one with data only import and also still having the same issues.

 

I'm at the point of just restoring from a backup. Backup data in Confluence in MySQL 5.1 and doing the upgrade to MySQL 5.5 and reinstalling Confluence from scratch then importing the data from Confluence backup.

This is getting ridiculous...

Same problem here today.

Did you find any clues ?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

Announcing Team Calendars in Confluence Data Center

Hi Community! We're thrilled to share that Team Calendars for Confluence is now a built-in feature for Confluence Data Center releases 7.11 and beyond.  A long time favorite,  Team Cale...

78 views 0 3
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you