Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,364,101
Community Members
 
Community Events
168
Community Groups

Dangerous HTTP methods are enabled on the server

Hi All,

Kindly suggest how to fix permanent solution and work around for this type of vulnerability (Dangerous HTTP methods are enabled on the server) and we are using Confluence server 7.15.2 version.

2 answers

0 votes

Stop using the methods that are "dangerous".  This doesn't have anything to do with Confluence, other than it being a web service you are running somewhere.  It can serve up "dangerous" methods, but it's up to you to configure your networking so that they are served in a not-dangerous way.

0 votes

The permanent solution is to not use the internet.

The vulnerability description is too vague and can be applied to virtually any website allowing any interaction between the user and the application.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events