Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Daily backups failing after upgrade to 7.2.1

I've had a daily backup that has been working properly for several years and many upgrades.

 

After the latest upgrade from 6.15 to 7.2.1, they have started to fail with:

2020-02-04 13:42:52,980 WARN [Caesium-1-2] [activeobjects.confluence.backup.LoggingBackupProgressMonitor] beginBackup Begin Active objects backup, change log level to INFO for com.atlassian.activeobjects.confluence.backup for more detailed logging.
2020-02-04 13:42:54,670 WARN [Caesium-1-2] [activeobjects.confluence.backup.LoggingBackupProgressMonitor] endBackup Completed active objects backup.
2020-02-04 13:43:01,784 ERROR [Caesium-1-2] [confluence.importexport.impl.BackupJob] runJob Error while running the scheduled backup
java.io.IOException: Permission denied
at java.io.UnixFileSystem.createFileExclusively(Native Method)
at java.io.File.createNewFile(File.java:1012)
at com.atlassian.core.util.FileUtils.copyFile(FileUtils.java:407)
at com.atlassian.confluence.importexport.impl.BackupJob.runJob(BackupJob.java:68)

I've tried changing the log level to INFO for com.atlassian.activeobjects.confluence.backup for more detailed logging (And even TRACE), but it doesn't give me any information on what file it's attempting to create and fail on.

3 answers

0 votes
Thomas Deiler Community Leader Feb 05, 2020

Dear @Adrian Gilbert

java.io.IOException: Permission denied

can you check if the service user running confluence has write access to $CONFLUENCE_HOME/backups ?

So long

Thomas

It has permissions to the directory /var/atlassian/application-data/confluence/backups

drwx------. 2 confluence confluence 6 Apr 14 2018 backups

And it also has permission to the folder that I've got configured for backups to be saved to, which is /mnt/Backups/confluence/

drwxrwxrwx. 1 confluence confluence 20580 Jan 16 02:00 confluence

It's interesting to note that the January 16th @ 02:00 modification time on the second directory is also the last time that the backups worked. 

And the confluence user can create files in the directories:

[root@03_confluence confluence]# sudo su confluence
[confluence@03_confluence confluence]$ id
uid=1001(confluence) gid=1001(confluence) groups=1001(confluence) context=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023
[confluence@03_confluence confluence]$ touch foo.txt
[confluence@03_confluence confluence]$
[confluence@03_confluence confluence]$ ls -al foo.txt
-rw-rw-r--. 1 confluence confluence 0 Feb 5 08:22 foo.txt

 

Thomas Deiler Community Leader Feb 07, 2020

Does Confluence run with the user "confluence"? Have you tried to set

chmod 777 backups

So long

Thomas

Hello? Anyone? It's still failing. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence Cloud

Please tell us how you use Confluence space settings

Hi there, a few of us at Atlassian would love to learn about how you use "space settings" functionality in Confluence. A facelift to the space settings is long overdue and we want to start with impro...

309 views 11 8
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you