Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Cursor appears as the "move" style rather than the expected "pointer" style over an image link.

Jacqueline Kushner May 6, 2019

When I hit "Publish", the cursor style over the image link appears as the move style (with 4 arrows - as a crosshair) rather than the pointer style. I do not seem to be able to change this in any available field or setting. I have heard that this can be "tweaked" in the global CSS but I do not know where to access it. 

I am running Confluence 1000.0.0. Any suggestions?

6 answers

1 accepted

1 vote
Answer accepted
Shannon S
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
May 8, 2019

Hello Jacqueline,

Welcome to Community! It's great to meet you.

The issue you are experiencing is actually a bug:

  • CONFCLOUD-57252 Move cursor is showing instead of pointer cursor when hovering over an image

At this moment, there is no workaround for the bug. You can help out by clicking on This affects my team so we can keep track of the number of affected users. If you watch the bug, then you will receive any updates on this, as well as if there is a workaround discovered.

I hope that helps! But do let me know if you have any further questions.

Regards,

Shannon

Jacqueline Kushner May 8, 2019

Thanks, Shannon.

Shannon S
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
May 9, 2019

You're very welcome, Jacqueline. Take care!

Regards,

Shannon

Deleted user June 12, 2019

actually go to space tools then edit css for ur space and add the following :

.wiki-content img.confluence-embedded-image, .wiki-content img.editor-inline-macro, .wiki-content table.wysiwyg-macro 

{     cursor: pointer !important;     }

Like # people like this
Shannon S
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
June 13, 2019

Hi Damien!

Thank you for sharing the workaround from the bug ticket on this thread. It will definitely help get it some visibility.

I will update the bug with this workaround so others can see it too, in case they missed it in the comments.

I tested this on my Cloud instance, and your particular version of the workaround does help solve the problem for pages which were created with the old editor. It seems I am not able to replicate the original problem with pages created using the New Editor.

Lastly, in case it helps anyone, Space Tools in Confluence Cloud is now known as Space Settings, so the path would be: Space Settings > Look and Feel > Header and footer.

Thank you again, and take care!

Shannon

Like Deleted user likes this
Deleted user June 13, 2019

Thank you for getting back Shannon, I'm happy to share, hopefully @Jacqueline Kushner this will help out

take care :)

kind regards,

damien

Like Shannon S likes this
Monica May 22, 2023

@Shannon S I am using Confluence Data Center, but if I follow the steps and add:

.wiki-content img.confluence-embedded-image, .wiki-content img.editor-inline-macro, .wiki-content table.wysiwyg-macro 

{     cursor: pointer !important;     }

 

I just end up with that same text displaying on the page, am I missing something?

Post03.png

0 votes
Derek Alex October 17, 2023

Wow, this is an issue from 2019 !  

4 years and is hasn't been corrected ?

Disappointing.

0 votes
Eric Coomes July 14, 2021

Hello,

I'm experiencing this issue on my team's confluence page. Has there been any update on the bug?

Thanks,

-Eric

0 votes
Abraham Toribio October 8, 2019

The workaround did not work for our environment. Any update on the bug?

Shannon S
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
October 11, 2019

Abraham,

It does appear that this workaround is no longer functioning at this time. I'm working to see if there's another way around that.

Could you let me know if you're on Server or Cloud? It affects both, and there's a 2nd workaround for Server:

  • CONFSERVER-57843 Mouse Cursor displayed incorrectly when hovering over attached Image in Confluence Page

Disable TinyMCE 4 editor and rollback to v3:

  1. Visit http://<conf-URL>/admin/darkfeatures.action
  2. Add frontend.editor.v4.disable to the list at the bottom

This change isn't possible in Cloud, but I wanted to check with you first on that while we see if there's another solution for Cloud.

Regards,

Shannon

Abraham Toribio October 13, 2019

Hi Shannon,

We are using Server Confluence 6.15.4

I tried the workaround you suggested and it worked. Thanks very much for your help!

Cheers!

Abraham

Like Shannon S likes this
Shannon S
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
October 15, 2019

Thank you for confirming, Abraham!

Unfortunately this won't work for Cloud as Jacqueline required, but glad to hear it works for your Server instance.

Regards,

Shannon

0 votes
Deleted user July 3, 2019

yeh you gotta CLICK THE FOLLOWING LINK and THEN u will find the button

https://jira.atlassian.com/browse/CONFCLOUD-57252?_ga=2.53651104.900742749.1562207122-1100633731.1562207122

Matej Dupal July 4, 2019

Sorry Damien, but when I access the Jira ticket I do only see the count of people who pressed that button, but not the button it self.

Capture.PNG

Shannon S
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
July 4, 2019

Matej,

According to the above screenshot, you are not logged in. Please log in when on that page (top right-hand corner). You will then be able to vote.

Regards,

Shannon

Matej Dupal July 4, 2019

You are right Shannon. I thought that when I am opening the link to Jira, I will be automatically logged in and I wasn't checking that. Many thanks for your help. I was able to press the button and I am also watching that bug. 

Like Shannon S likes this
Shannon S
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
July 4, 2019

Glad to hear! Thank you for confirming.

Take care, and have a pleasant rest of your week.

Regards,

Shannon

Like Matej Dupal likes this
0 votes
Matej Dupal July 3, 2019

Hi,

I do not see the button This affects my team. Where can I report it?

BR,

Matej

Shannon S
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
July 3, 2019

Matej,

Welcome to Atlassian Community! If you're not seeing This affects my team, it is in the top right-hand corner of that request, again the link is here:

  • CONFCLOUD-57252 Move cursor is showing instead of pointer cursor when hovering over an image

It's there whether or not you are logged in, but in the event that you are not yet logged in, it appears in grey. This might be the reason you're having a hard time reading it. If that's the case, look in the upper top-right, and you'll see where it says Log In. You can login here.

Let me know if you have any trouble.

Regards,

Shannon

Matej Dupal July 3, 2019

Hi Shannon, 

Thank you for your super fast reply. Below is the picture of what I see in the top right-hand corner. I am logged in and I still do not have the button available there.

Atlassian Communicty 1.png

Shannon S
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
July 4, 2019

Matej,

You need to first click on the link to the bug ticket. Once you are there, you will be able to vote on the bug.

I'll include the link again here:

CONFCLOUD-57252

Thank you!

Regards,

Shannon

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events