Currently unable to log into admin account for Confluence

I have tried to log into Confluence with both the admin account and my account. I know both passwords and neither one of them are recognized. I have then download dbvisualizer 10.0.2 and have connected to my database located at C:\Program Files\Atlassian\Application Data\Confluence\database\h2db. I have followed along with the information provided as far as the connection type, Databse driver, h2 embedded, SA for database Userid, I have left the password blank and have connected to C:\Program Files\Atlassian\Application Data\Confluence\databaseh2db. When I run the following script, select u.id, u.user_name, u.active from cwd_user u join cwd_membership m on u.id=m.child_user_id join cwd_group g on m.parent_id=g.id join cwd_directory d on d.id=g.directory_id where g.group_name = 'confluence-administrators' and d.directory_name='Confluence Internal Directory'; I get an error stating that the Table "SWD_USER" not found; Sql statement: 
I had thought that it may be how I was connecting, so I used DBeaver to see the database with some other program. I connect to the database and still receive the same error. Could you please let me know what others steps I need to do in order to get either my username or the admin password reset to something that I can log in with? Thank you

3 answers

Please use following guide: https://confluence.atlassian.com/doc/restore-passwords-to-recover-admin-user-rights-158390.html

And pay attention to table names (SWD_USER <> cwd_user).

0 vote
Ann Worley Atlassian Team Oct 30, 2017

Hi Jon,

I understand you are having trouble logging into your Confluence instance using the Embedded H2 Database and following Restore Passwords To Recover Admin User Rights. The latter guide will help you change the admin password to "admin" and get logged in.

The error you report, " table SWD_USER not found" hints at the following possibilities:

  • There was a typo in the query when the table "cwd_user" was specified
  • There is a typo in the error you are reporting, meaning the cwd_user table was not found. If this was the case, please investigate further by making sure the cwd_user table does exist. To check, please run 
    select * from cwd_user; 
  • or else list the tables in the database and make sure the table is there.
  • Sometimes case sensitivity can be a factor so you might also look for the CWD_USER table.
  • Since you are using SA to connect I think we can rule out insufficient permissions on the database user.

I have used the guide Restore Passwords To Recover Admin User Rights many times with excellent results. If you run through the steps in order I am optimistic that you will get logged in.

Thanks,

Ann

Thanks Ann, however I am still getting the same errors.  I have attached 3 screenshots that may be of some help.  Thanks again.

1.PNG2.PNG3.PNG

Ann Worley Atlassian Team Nov 01, 2017

For anyone watching this thread, we are having a private conversation on this and will update the Community when we have found a resolution.

0 vote
Ann Worley Atlassian Team Nov 02, 2017

Update - We were unable to retrieve the data from the H2 embedded database but Jon had an XML backup handy so we installed a new instance of Confluence and restored the data from the backup.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Thursday in Confluence

Three common content challenges + how to manage them

An efficient enterprise content management system, or ECM, is a must-have for companies that create work online (cough   cough, all companies). If content calendars, marketing plans, and bu...

72 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you