Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Copying data with decimal points changes numbers to 1.

I'm copying data from Excel to a table but numbers like:

 

7.94

5.12

are automatically changed to a numbered list 1.94 and 1.12

I can't copy using CTRL+SHIFT+V because then the data won't go into the cells properly. Can we disable this automatic list? It's a terrible experience!

3 answers

Hi @Dawid Nawrot 

When you say you are copying data from Excel to a table, are you simply copying a couple of rows in your Excel and then dropping them into a blank page, which auto creates the table or are you copying into an already defined table? 

I ask because I just copied a couple of rows from a sheet in Google & Excel with numbers containing decimals and pasted into a blank page. It worked just fine. 

I also copied and entire column of decimals, and it auto-created a table with all the values in it. 

I also copied the decimals and overwrote my cells in a table and they too copied okay. I am not experiencing what you are experiencing.

I use Right Click Mouse and Paste - works perfectly,

I also tried CTRL+V to paste - works perfectly. 

row vs column paste.png

-Mike

I already have a table because I built the structure in confluence and then copied the table and then filled it with data. Unfortunately it changes things like 8.25 to 1.  25

@Dawid Nawrot

What i do sometimes is use text concatenation in to a helper cell with wiki markup. Then copying that in to a wiki markup marco. 

E.g. in Excel Column D

Header Row function ="||"&TEXTJOIN("||",FALSE,A1:C1)&"||"
Other Rows function ="|"&TEXTJOIN("|",FALSE,A2:C2)&"|"

See more info about wiki markup for tables here:

https://confluence.atlassian.com/doc/confluence-wiki-markup-251003035.html#ConfluenceWikiMarkup-Tables

Hi @Dawid Nawrot 

Spotted on another post... Someone else has logged this problem with the Support Desk. They advise you click the link below and watch the issue (hopefully get resolved).

CONFCLOUD-68744 Pasting single digit decimal numbers in new editor results in numbered list replacing the first digit

It appears to be related to the formatting, so pasting the contents into a code block or pasting from a raw text document appear to work without auto-formatting to a numbered list.

 

-Mike

Thanks for this link Mike. I am seeing the exact same issue. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What do you think is the most *delightful* Confluence feature? Comment for a prize!

- Create your own custom emoji 🔥 - "Shake for Feedback" on mobile 📱 - An endless supply of GIFs via GIPHY 🤩 Is there anything quite as nice as a pleasant surprise? Comment below with what...

383 views 23 8
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you