It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Copy and paste from excel to confluence table?

Hi

I'm editing a page in confluence ( in google chrome) and i need to add a table from excel into confluence. When i copy and paste the table across though the cells get pasted only in the first cell of the table in confluence. How can I copy and paste the table across so that the format stays the same? 

11 answers

You can also create a 1 cell x 1 cell table and paste the Excel table into the cell and Confluence will build out the table correctly.

But this does not work if you try to do this within a page 'Section' - only if you are outside a 'Section' so within the page body itself.

Also:

If you want to enable the Confluence feature which allows the sorting by column when the page is in display mode, you have to create a table which has a header row with the exact number of columns in it.  You then copy the Excel table, and paste it into the left-most column (first column), and Confluence will build the table out, and sorting will be enabled in display mode.

Like # people like this

for me it also does not work, but i'm doing it in JIRA and not in confluence.

In JIRA, you can use this handy tool to make the table markup:

http://excel2jira.bluurgh.com/

It's fantastic.

 

Jira don't do tables like Confluence does.  :-(

yeah I use that one for a while now, after I did some google.

it would be nice if it could be a plugin though. or maybe is not active in my jira. I'll look next time i go into the markups

Agree, and it's annoying to have to use this every time we want to change the table, or we have to actually navigate the markup.

Even more frustrating that there is a "table" button on the "Other" menu, but all that does is insert the markup.

Kate Hanna THANK YOU!!!

I have been unable to make this work. Confluence insists that it will only paste one cell from Excel. 

I have tried

  • Creating a 1x1 table in confluence and pasting the Excel table - doesn't work
  • Creating a same size table but pasting into the first cell (A1) - doesn't work
  • Creating the same size table, selecting the entire table and pasting - doesn't work. 

 

I have multiple tables that are just easier to manipulate in Excel with hundreds of row, there must be something I am doing wrong. 

Like # people like this

Hmm, this is something odd with the way the table is copied from Confluence -> Excel, then back from Excel -> Confluence. If I ignore the first row (in Excel) of what I originally copied from Confluence, then I seem to get something that works and can be pasted back to Confluence. I just then need to re-add the first row. 

Talk about cumbersome and unintuitive. 

Bill_Bailey Community Leader Feb 18, 2018

Have you tried with Firefox? I have noticed that tables seem to work differently (and better) in Firefox. I am able to copy from Confluence, place a cursor in an Excel cell, and paste. The table pastes correctly.

Like Tim_Daniell likes this

Chrome works for me, but can't paste tables with FF (browser extensions may affect this)

What a pile.... NOTE you can only cut and paste when outside a section as above

Google Chrome did not work for me but Firefox worked perfectly.

Like Mark.Olsen likes this

Excel to Confluence cut and paste a table worked for me with Google Chrome, but not with Microsoft Edge.

Like Swayamsiddha likes this

it works for me, cut and paste from excel to confluence in the table with same row and columns 

I was also unable to paste into a table using Chrome. It pasted into a single cell.
Then I tried Firefox (on my mac) and it didn't even let me enter the "Edit" of the document!
Then I tried Safari. Poof! Worked like a charm.

I just managed to copy a table from Excel within a section on Internet Explorer. Go figure!

I created a table with 1 row and the same number of columns in Confluence and then pasted my Excel table including the header. It worked!

Just tried to do this by creating a one cell table in Firefox, then pasting a two column table with many rows (copied from Excel). It worked great.

FireFox worked for me as well. Well, no formatting came across but at least the data is there.

I had to make sure WRAP TEXT was on for all cells.

Hi Krisan

You need to either select an identical layout for your table to match the number of columns/rows being copied across or not copy into any table in which case Confluence will then create the table for you to the right size.

Also:

If you want to enable the Confluence feature which allows the sorting by column when the page is in display mode, you have to create a table which has a header row with the exact number of columns in it.  You then copy the Excel table, and paste it into the left-most column (first column), and Confluence will build the table out, and sorting will be enabled in display mode.

Hi krisan, 

If you want to copy paste single or multiple rows from excel to confluence, just create new rows (whose number equals to what you are trying to paste). And copy the rows from excel and paste them in the first empty cell.

If you have any problem with this, better create a new page in new tab and paste the table, then copy the rows and paste it in the page where you want to insert, before that create a single empty row.

 

This worked for us, thanks Uma!

This won't help everyone, but I'll leave it here in case.

My workflow was Excel to Confluence Cloud via Safari, inserting into a blank 1x1 table. That used to work but today it didn't.

My new workflow is:

  • Copy from Excel
  • Paste to Numbers
  • Copy from Numbers
  • Paste to 1x1 table in Confluence

Can't tell if I'm experiencing user problems or if there's something else going on, but this method works for me and might be useful for anyone working on Mac.

Are you able to retain your excel formatting?

One workaround that worked for me was copy&paste the table from MS Excel to MS Word. Copy again from MS Word and than paste to Confluence. Now the table was created even with header row being recognized.

Worked for me. I had created an empty table with only headings, and pasted the contents from Word to that table.

Make sure you are pasting via the right-click menu (and selecting "Paste") rather than pasting via the CMD-V method...

This worked for me. Thank you...!!! :)

I need to know if there is an automatic way to import the file that I need to make available on the platform. The file is a table with more than 3800 rows and I need a page for each of these rows.

I just solved this by:

-Created a table in Confluence with the appropriate amount of columns (didn't worry about rows)

-Copied table in Excel 

-Pasted into Word (this made a nice table for me without me having to do anything)

-Copying this table from Word into the confluence table

 

Hope this works for you :) Note I was using the Office 365 web app versions of excel and word but I can't imagine this makes a huge difference.

Works to me, thanks

Hi all,

If it isn't pasting from Excel properly (I.e. pasting everything in the first cell), save the confluence page and then click edit page again and the paste seems to work for me after that.

 

Rowland

This worked for me. Thanks!

I wanted to add my two cents - I was trying to copy from Excel Online and none of the above worked. Eventually I downloaded the sheet and the copy and paste worked like a charm - even though I was in a section and the table wasn't the right size to start.

Here is my workflow to get around this obvious need in Confluence.

1. Open the target Confluence page in edit mode.

2. Use the following URL to paste your table.

https://excel2jira.bluurgh.com/ 

Note: Yes, the above link is intended for Jira but the markup syntax it generated is universal.

3. Copy the converted table data, now in markup syntax

4. Back in Confluence, use "Ctrl+Shift+D" (Insert Markup), paste your markup into the insert frame (left), verify the preview, select > insert and bingo, the markup pastes into my page as a table.  I have not seen it fail yet but I am sure there are some limits (Size, conversion, etc.).

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What project did you transition or start on Confluence with the shift to remote work?

It’s been great to hear from fellow users over the last few weeks about the best tips and fun moments you’ve had working on Confluence since the transition to working remote. I’d love to keep the c...

345 views 11 11
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you