Content Survey and Reporting Plugin: Error message when trying to use survey macro

The Content Survey and Reporting Plugin does everything a lot of things we want for our new Confluence-based knowledgebase, but I'm having a really tough time getting it set up.
I finally have it installed, but now when I put the survey macro on a page, I get the following error:
Error rendering macro 'kbsurvey' : Cannot construct com.atlassian.confluence.plugins.knowledgebase.config.SurveyQuestion as it does not have a no-args constructor ---- Debugging information ---- message : Cannot construct com.atlassian.confluence.plugins.knowledgebase.config.SurveyQuestion as it does not have a no-args constructor line number : 7 path : /surveyconfig/questionMap/entry/surveyquestion cause-message : Cannot construct com.atlassian.confluence.plugins.knowledgebase.config.SurveyQuestion as it does not have a no-args constructor class : com.atlassian.confluence.plugins.knowledgebase.config.SurveyConfig cause-exception : com.thoughtworks.xstream.converters.reflection.ObjectAccessException required-type : com.atlassian.confluence.plugins.knowledgebase.config.SurveyQuestion -------------------------------
Anyone have any helpful hints?
Added a 10 Karma bounty. I'd like to get this fixed.

I'll also acccept an answer for a suitable alternative plug-in with the same or similar feature set.

6 answers

1 accepted

Sorry about that. I didn't realize that location was not public. Here is a link to the version which will hopefully be released soon: Download link.

Edit: The plugin has been released in the Atlassian Marketplace :)

Thanks Alex. I've installed this version and the plugin appears to be functioning correctly.

It may be some time before I have a chance to test this, but I will mark this as the accepted answer because someone else successfully tested it.

Hi Eric, which version of Confluence and of the plugin are you using? I've not seen that issue before. How many questions have you defined for the survey in your test space? I'd suggest making sure you add one more to the default question as a test. If that doesn't help then you could try resetting the survey via Space Admin.

Confluence 4.2.6

Content Survey and Reporting Plugin 1.1

I cannot define any test questions now, either.

When I first installed I left the default "was this useful?" question and added one for "was it well-written?"

I then went to a page and added the macro and began to get the "no-augs constructor" error you see above.

Now I can't get back to the survey pages. When I go to the Space Admin page and click either of the Survey options, I get an error page that has the same "no-augs constructor" error message.

I tried uninstalling and re-installing the plugin today, but it did no good.

Hi,

We're using Confluence 4.2.1 and the exact text of the Content Survey & Reporting Plugin (listed as Knowledge Base Survey Plugin in the admin screen) is 1.1-SNAPSHOT.

We ended up with this version after witnessing the issue described here: https://studio.plugins.atlassian.com/browse/CKBSP-27

The JAR file attached to that issue is for mySQL only. From your earlier question I know that you're using that database so it may be worth trying that specific version of the plugin. However, that's your call of course! There don't seem to be any issues listed in Jira for this plugin and the keyword "no-args constructor".

It might also be worth checking that your mySQL database is set-up along the lines recommended by Atlassian (https://confluence.atlassian.com/display/DOC/Database+Setup+For+MySQL). The options for character encoding (UTF8), case sensitivity and InnoDB are important ones and may have a bearing on what you're seeing with this plugin.

Regards,

Charles

I've tried the 1.1-SHAPSHOT version as well, actually. Same problem.

I'll pass the mySQL setup link along to our IT group and see if that helps. If it does I'll approve this answer. ;)

Sadly, none of the above worked.

We checked the database against the setup for MySQL page (and the associated common issues page) and did fix one or two little things.

However, that did not fix the Survey plugin. Still getting the no-augs constructor error.

I tried both the regular and the -SNAPSHOT version of the plugin.

Are there other plugins that duplicate some or all of the functionality of the survey plugin? We mostly just want to insert a short questionnaire on each page and have a way to check on the results in a centralized location.

The other features of the survey function (like macros to list helpful pages) were just gravy. Tasty, but not required.

0 vote

Hi Eric,

Sorry it took me so long to see this question! We're just about to release a new version - 1.3 - which uses ActiveObjects for the data storage. You can download a copy of it here. We didn't fix any bug like the one you're reporting here, but it'll at least eliminate the confusion around which version, as it's database agnostic.

If you still have that problem in 1.3, we'll add a no-args constructor to that object. I'm puzzled by why I can't replicate it, but no matter, it should be an easy enough fix.

Thank you Jeremy. I will give this a shot and report back, although it could be a few weeks before I get the chance.

We've updated to v1.3 and are getting the same issue reported by Eric.

This is a problem with the old plugin and Java 7. It is fixed in the latest version I am working on and it should be released soon.

I have uploaded a beta of the plugin which should fix the problem. It is compatible with Confluence 4.3 and later.

Enjoy it and any feedback is welcomed :)

Hi Alex, I'm not able to download this plugin. When I get there I have to sign in, and I did so from my personal BitBucket account but it says I do not have access to that repository.

Is that download private or am I doing something wrong?

Hi I'm using confluence 5.1.3 and using pluging version 1.3.2.

I'm getting the following error in preview:

Error rendering macro 'kbsurvey' : null

i figured out that if i edited the default question the plugin started to work (just saving the config with no changes did not work).

survey does not seem to be working on any space home pages.

What's not working - is it giving an error?

My appologies, survey is working on the space home page, it was a cache issue causing the survey to not display.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

377 views 20 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you