Connection test failed. Response from the server: com.atlassian.crowd.exception.ApplicationPermissionException:

I am trying to connect Confluence to JIRA for user authentication.  I have followed all the steps (Even disabled whitelisting on both) but when I test the connection I get.

 

Connection test failed. Response from the server:
com.atlassian.crowd.exception.ApplicationPermissionException: ��YYs��~ϯ�聹�Y�-+؞ $p�P��J��-����n��a����6ks2ax�P�����O�^ttT�-6"�V� �:R�o!����y�|�1I��8��߅^� �d�I�>�Pyyv�Z���$��W��:Z���L(b���*� B�A�����[Ĕ M$� e����^7ܫ�-Mp��|z��?����oO�����'���1G2V�G�avj����@9�� �� 7��Q6`�H���^�-\ [v�]��[NF����F��tK�4+��C�F]�(�{X"��I�+� F���Le0ۑ��Q޵=-���{�K��:b���sn h�� J8�Mm�����`Cp �a��`9�ƀ�>��bc��YB�&|����}p���;}l��Ɛ#n�F)�`C�5� TT9���b��&_��5H��r�\� gT�:�Y��J�J�(��Rp�+(��'$ �c�=0� %hM��VߪJ���0 O0�׌n\�U̅�(�ۃB(�o��8| �J�A��4W 5��@ը�j'B�`3�Ҡ���8�cfB˕C(�ۣ �&ۊ�(���Zs�v۽0}碌��&�͑���\�,���� �I�E)�n��(����̧��8t� �U����Mb"`�Ѽk�{mR��Zh�ms��{� ט�(p�!q}� o�e:�&�e�$Q���Fv�&��d-x(z\,�(�Q�r �iD�K�uq��n"��]���'7h�y�Ɣ��8�nn���~� �p�P���=g:7 34]�i�Ȱ̓A��ν���f��C2�B�y& �3�M� R�2J�+���}��������SH3����D� ��� 8�� ��.��k�("K�h/���j���>�BDz��5�������� ��S� ��/›�j��G�`1�T͐��*҇G�t {n6rm�2l� g^h9!������W��ha�U�X^��|���й�>�W��7C؛�ln��4�|b�=s:��������7�� -L�,��SIQ��_�^�W/ߟ�J��+��ъp �B�wu6q&��xz��n�x�P\��҂��jڥ�P�c�V4\^�*,���l,9�UբT�1�m�-�3�h��4�@��RD���$(.X�Y�P�����À�$ ���`1f�@� �1��=�{3���R��˼�����(�1��\`���p^r�EC�8��~`��QZ���D Ъ��B��Β �!݌`)� �d����� ur}!�

 

They are both hosted on the same box, and JIRA is authenticating fine.  I have connected to the rest service through a browser and get the same.  Authentication details are correct.  It just seems that JIRA is returning rubbish.

11 answers

I received this error as well when attempting to connect to our JIRA instance via the URL we had setup with Apache. Apache in our instance is proxying to our JIRA instance. I used the FQDN of the JIRA server including the port number and everything worked great.

We are also using Apache and have just started getting the same error.  The line noise up above accurately reflects what we see both in the logs and the user interface.

To fix this rubbish message try to disable GZip compression in JIRA general settings:snapshot2.png

Good luck

The first problem, the funky text in the response, is solved with vlad's solution: turn off GZip compression.

Then you can read the actual error message, which is really a 403 error.

My solution is to put your server's IP address in the IP Addresses box (no need to put the port number), even if you are using the same server for both JIRA and Bitbucket (or any other Atlassian product).

 

this is the solution to solve my problem. somehow our crucible server cannot resolve the common name of jira server (crowd), after add the entry into /etc/hosts, it works.

the first step: disable gzip. allowing me to see the real error.

Hi Thomas,

The first line of the exception is the only one readable. As far as I can see you might be facing the issue reported below:

https://confluence.atlassian.com/display/CONFKB/Exception+when+delegating+user+management+to+JIRA

If that's not the case I would suggest you to open a case against Atlassian Support and add there your support.zip file for deep analysis on the logs.

 

Cheers,

Hi

Did you resolve this? I am getting the exact same error.

Chris

I am having same issue as well. application links are established, application/pw is created, whitelist is set, yet it is still not working

Plz check my suggestion below

Hello,

I had this problem after cloning JIRA and Confluence servers. I solved the problem making sure the servers were able to resolve themselves ok, that the hostnames were ok. Their hostnames were setup with the original servers hostnames. I changed the hosts file to be like this.

 

root@jira:~# cat /etc/hosts
...
127.0.0.1 localhost
127.0.1.1 jira.mydomain.com
NNN.NNN.NNN.NNN jira.mydomain.com jira
...
root@jira:~# hostname --fqdn
jira.mydomain.com
 

Cheers,

 

Enrique.

I've been fighting with this all morning.

The answer was surprising. I have Confluence hooked up to JIRA via an application link, and when the application link was created, it set itself up to use the JIRA user directory.

I went into the Confluence admin and noticed that the user directory entry was set to type "Atlassian Crowd", not "Atlassian JIRA".

So in Crucible, I created a new user directory link and chose "Atlassian Crowd" as the user directory source - NOT "Atlassian JIRA" - and it worked.

I faced the same issue after installing a new confluence instance and restoring data from another instance. We use MySQL as the external DB.

I was unable to login via the GUI and the way I resolved this is by;

 - logging into the MySQL instance

- use confluence; (or the relevant DB name)

- select * from cwd_directory_attribute;

This displays all CROWD configs details and it would contain the config of the Confluence instance you restored  from. Modify as needed and restart confluence.

After created a new "user directory", then this issue gone.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Tuesday in Confluence

Confluence Admin Certification now $150 for Community Members

More and more people are building their careers with Atlassian, and we want you to be at the front of this wave! Important Dates Start the Certification Prep Course by 2 April 2019 Take your e...

193 views 2 10
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you