Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Connection Error: We've lost our connection to you...

Ridvan Baluyos September 9, 2021


I'm trying to figure out why everyone on our team using Confluence is getting the following error when editing certain pages:

We've lost our connection to you, so we've disabled editing to prevent any issues. You'll be able to edit once we reconnect. Trying to reconnect..."

Screenshot 2021-09-09 171638.png

I'm pretty sure it's not our internet. We're on 900+ mbps. We could browse other websites. And we could edit other pages on our Confluence.

Our team has been using Confluence for 2 months already, and we're trying to propose using Confluence Cloud to our management as a standard user (above 10 users). But if this is the kind of connectivity issue that we'll encounter when we onboard everyone, how could we possible propose this to our management?

I've done my due diligence searching through the community, but none of the accepted answers solve anything other than "it suddenly worked."

This is really frustrating since we've done a lot of work already on a certain page and we could not even edit it.

One of the things I've observed is when there's a large entry of rows in a table inside a page. 


Things I've done:

- Logout/Login Atlassian

- Cleared browser cache

- Used a different browser

- Restarted PC

None of the above solved the issue.


Could anyone from Atlassian help us on this? 




17 answers

1 accepted

7 votes
Answer accepted
Alexis Robert
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
September 9, 2021

Hi @Ridvan Baluyos , 


it looks like Atlassian is aware of performance issues with large pages, as several bugs are currently being worked on : and


Since Atlassian is working on these, I don't think there an immediate fix to your issue rather than "try to break up your page into smaller pages".

I would advise adding a comment to these tickets, so that Atlassian know you're impacted.


Hope this helps, 



Ridvan Baluyos September 9, 2021

Hi @Alexis Robert 

Got it.

At the moment, we split any page that contains large information on tables. Apart from the tables, we do not see this happening even for pages which contains many images ( diagrams).

But wow, the issue has been filed since 2018 and they seemed to have a hard time fixing it. 

Thanks for the reply. I've added my comment already.



Paul Devadatta September 13, 2021

This has nothing to do with page size.  I have a new page, and it has taken me 10 minutes to type one sentence.  Every few letters, it displays that message, and stops accepting any input (which of course I don't notice).  It takes a while (sometimes minutes) to connect again, and I can resume typing.  

My network is fine.  I'm using several applications that have had no network problem.  This definitely looks like an issue with Atlassian servers.  

The two Jira issues mentioned don't really address this specific issue, with this specific message.  

Anyone in Atlassian looking at this issue?  

Mark Skurnik November 8, 2021

I am also experiencing the same issues

Preethisha Gopinath November 9, 2021

Same issue, was the confluence team able to fix this?

psagar November 10, 2021

I am having the same issue with the confluence page.

"We've lost our connection to you, so we've disabled editing to prevent any issues. You'll be able to edit once we reconnect. "

Ana-Maria Galai November 11, 2021

we are having the same issue as well

Joe Lagana-Jackson December 10, 2021

This just started happening to me this month. I never had an issue before. I hope it's fixed soon.

Adriana Mandjarova (Old) December 19, 2021

Same problem. Hope it will be fixed soon.

Brian Jakobsen December 19, 2021

Same issue. We need it fixed

Peter Bysøe December 19, 2021

Need fix

SISI (Syamsi Kusyanti) December 20, 2021

same issue, we hope it's fixed soon

Paul Hayden January 20, 2022

This feature is terrible :( :( :( 

Why are you not saving this on the client and then synching the data model when the connection is available.

Atlassian you should be ashamed of yourself for not fixing this immediately.

I be avoiding using your version 2 editor at all costs from here on in... January 30, 2022

Same issue here as well.

Adrian Schlatter February 1, 2022

Have this issue as well on a page containing only 2 words.

Yann DOUCHIN April 20, 2022

Having the same issue repeatedly here. I really hope it'll be fixed soon, it's so frustrating...

Dave Hab April 25, 2022

This problem has appeared for me in the last week or two. It's frequent enough to be extremely interruptive. Right now, it's happening every 15-30 seconds.

Dewayne Watt April 27, 2022

My page has a title, a warning, and a note.

I am losing connection and unable to edit the page.

This is horrible user experience... to the point that I came here to complain.

Confluence is a terrible product that I am forced to use.

Dewayne Watt April 27, 2022

Literally after spending 3 minutes here to write up my issue, I return to my Confluence page, made about 2 edits, and now I see:

We cant show this page

The permissions for this page were changed.

Contact an admin for help.

Edit: turns out this issue is because I made a new account to complain, and was signed out of my previous account on my other pages.  

ecoea May 19, 2022

I have 1gbps symmetric Internet and only Atlassian Confluence has the performance issue.  Someone thought it was chrome browser spellcheck.  I disabled it to no different. 

I am working with the Confluence Cloud and the on-prems version, for both I am accessing and authoring over the Internet from home.  For the same remote use case, the on-prems side is fine, so it rules out the Internet bandwidth. It is the Confluence Cloud one that the issue persists.

The problem is worst when using a "Table filter" that has more than a few hundred rows!

Like Jason Misquith likes this
Minsoo Nam June 4, 2022

same issue

Like # people like this
Anirban Paul August 18, 2022

Facing the same issue.
This was not the same till a few days back.
Checked on my network speed but that does not seem to be an issue

Thomas McCroskey March 19, 2023

This issue still hasn't been fixed by March of 2023, seemingly five years after it was reported.  I'm lobbying my company to find a different product.  Our pages are not that large.

Anmol Saxena December 12, 2023

I am also impacted due to this issue.

1 vote
ecoea March 19, 2023

Break up large pages and large tables using hierarchy, i.e., "display children" macro.

The problem typically associates with large tables that are wrapped around other macros.  This also manifests another issue: when wrapped with other macros, the confluence tablet or smartphone apps do not know how the present it in a friendly way, resulting in worse UX on the page.  

Roshan Sharma August 10, 2023

Confirming this helps! I have limited extensive use of tables and other widgets in my docs and started breaking up my documents into hierarchies. It doesn't always prevent this issue from occurring, but at least I can "kind of" work with my pages. 

1 vote
Thomas McCroskey March 19, 2023

Atlassian seems to have no interest in fixing this problem after all this time.  I suggest switching to a different product.

chike March 30, 2023

I'm just glad i'm not going crazy. Or we are the crazy ones and this is how we find each other...

1 vote
Mark Skurnik November 11, 2021

My issue has now been resolved. This came back from my IT department

"We’ve found that the site is redirecting or connecting to site using Web Socket connections.

This has only recently been implemented and as a result, the recommendation is for customers who proxy their traffic to bypass all traffic for from being proxied."

Paul Hayden January 20, 2022

Interesting... I don't normally bother trying to chase things like this but my frustration with this issue has moved to the next level.

I'll raise this with the IT department - thanks.

Thomas McCroskey March 19, 2023

We don't use a proxy for our at-home locations.  So this wouldn't fix the problem.  We still have the problem.

0 votes
Geoffrey Moes March 19, 2024

A client of mine recently had this issue. We were able to narrow down the problem to be specific to the client's network, as editing the same pages outside the network did not generate the error.

In the end, the problem for us was the client's security software blocking the websockets connection that Confluence uses for collaborative editing. We resolved the problem by putting Confluence on the list of sites for the security software to ignore.

0 votes
Ronan September 14, 2023

Same here. I cannot update any documentation since it's blocking for the work of my team. 

0 votes
Ginette Anderson May 10, 2023

Having this issue accrossed all departments who use this platform as well; it's very annoying.

We don't want to split content into different pages, when is this going to be resolved? 

0 votes
marcel Van Der Vliet June 20, 2022

Having the same issue, very frustrating.

0 votes
Cham June 3, 2022

Same issue. Any help?

0 votes
Benton June 2, 2022

This often happens to me as well! Crazy that there's no solution on here yet...

0 votes
Dewayne Watt April 27, 2022

Looks like some update a month or two back that's now propagated enough to disrupt many user's experiences...

0 votes
Rebecca Vredenburg April 22, 2022

We have this same issue - but it resolves if we disconnect our VPN.  The VPN doesn't have any special security settings - and works find with all other websites.  Not sure if that is relevant, but maybe it will help someone figure this issue out.  

0 votes
Tony.Shoemaker April 19, 2022

I've just started having this same issue starting today.

0 votes
Anish Sathyan April 6, 2022

Same issue here .It is really frustrating 

0 votes
Jonas Burghardt March 30, 2022

Same issue. Whole team is reporting this error repeatedly.

0 votes
Antonio Calì March 14, 2022

Same issue and it'not accettable since it's blocking for the work of the whole team.

0 votes
Luis Ramirez March 8, 2022

Same here. It's really frustrating.

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events