Confluence v4 editor is driving us insane

We finally moved from 3.5 to 4.2.4 on the weekend, though this new editor is driving our users up the wall. The feedback is that it feels too beta like.

Some of the strongest complaints we are dealing with are:

# *Macro Browser*: For heavens sakes, we need to bring this up almost all the time now. In the past it was so simple that if you knew what the parameters were you could just type the, but now you have to click the macro, find the parameter, click it, type, click the next type.. agh; can't we just type this as we used to? Myself and others have bad eyes, we can't even see our mice at times, I also have RSI in my mouse hand and have trouble using the stupid thing, it's inefficient and much faster to just use the keyboard (and don't quote those cryptic keyboard shortcuts).

# *Copy and paste*: It's extremely unpredictable, and always tries to copy the surrounding macro from the copy. What's worse is if you copy inside a {{noformat}} or {{code}} block, and paste into that same block, the editor loses the plot, you can't delete the content, everything just s**ts itself.

# *Whitespace control*: there's no way now to be able to control white-space. Previously it would ignore the white-space, but now we end up with strange behaviour where a macro needs a new-line before and after it (say the {{note}} macro), yet you can't control this white-space. Try creating a heading, then excerpt in just one page and see what happens, the excerpt leaves either a massive whit-space or none at all.

# *Tables*: They're just wrong, trying to insert a table using the familiar wiki markup is unpredictable, type || test || {{press Enter}} and it behaves as expected, but try either || Test | test | or || test || test | and you end up with four columns. Content inside a cell is now extremely hard to control. Try putting a note inside a cell and see what happens.

# *Lists*: Don't ever try putting a macro in a list unless you want to screw the whole list up, they start going way out of control.

# *Images*: You can copy+past an image from your clipboard (like a screenshot), appears fine, but no attachment is uploaded and the image of course doesn't render. Also if you happen to accidentally drag + drop an image in a page, for example if you click an image to bring it up, then accidentally move your mouse slightly when clicking that image, it adds that image as an attachment to the page.

It has only been 3 days and we're going crazy.

We have contacted atlassian prior to the upgrade to see if we could get the wiki editor back but this proved fruitless.

The reasoning behind storing as HTML IMHO is flawed and should be thrown away; Douglas Crockford|http://www.crockford.com/ agrees. Why not just have used a {{JSON}} format instead? The argument around round tripping would have been solved.

6 answers

1 accepted

Confluence Wiki Plugin might help with a bit of your pain :(.

Thanks Bob, it helps, though I think we could never be as efficient as with the old wiki editor. With <4.x I used to type of the macro that I couldn't remember the arguments for, move my cursor and then hit the macro button which would allow me to fill in the parameters, though most of the time I would remember.

True and the notation guide is gone as well :(. I have kept the online documentation based on the parameter names for my plugins, but Atlassian removed theirs and they mentioned trying to put that back.

Ah yes, they did mention it was done by mistake. What is also a shame is the default parameter is no longer supported, I.e. you need to type {code:lang=java} instead of {lang:java}. I didn't realise this at first and assumed that params were not supported by the new editor, it wasn't until recently I discovered this fact.

The (only?) best solution I've found when dealing with the quasi-WSYWIG editor is the Source Editor plugin. Solved 98% of my issues. And its free.

https://marketplace.atlassian.com/plugins/com.atlassian.confluence.plugins.editor.confluence-source-editor

Thomas Schlegel Community Champion Jun 13, 2012

And yet another commercial plugin we have to buy just to remain the status of version 3...

Wikifier RT might help, too (especially in conjunction with Bob's Wiki Plugin).

0 votes

For anyone interested, I've worked with Brett to replicate these and have recorded them here:

https://jira.atlassian.com/browse/CONF-23923
https://jira.atlassian.com/browse/CONF-24095
https://jira.atlassian.com/browse/CONF-25925
https://jira.atlassian.com/browse/CONF-25926
https://jira.atlassian.com/browse/CONF-25927
https://jira.atlassian.com/browse/CONF-25928
https://jira.atlassian.com/browse/CONF-25930

For anyone with editor issues or suggestions please contact us via support.atlassian.com - detailed steps on how to reproduce the problem are appreciated so we can record the bugs accordingly.

I've diagnosed and proposed a solution for CONF-25930.

Michael, just a suggestion: in addition to requesting detailed steps to reproduce the problem, you might also wish to consider requesting - if applicable - the RTE HTML and - again, if applicable - the corresponding rendered (preview/display) HTML that demonstrates the problem (that is, the HTML that is created by following the steps to reproduce the problem). Yes, this is, potentially - given accurate steps to reproduce the problem - redundant information, but sometimes that redundancy can be useful, especially when reproducing the problem might hinge (as some current quirks do) on details such as whether one begins selecting a word from the start or the end of the word.

Michael, a nit in your comment: that block of JIRA URLs is a single link to CONF-25930. In the rendered HTML source, that block consists of one p element containing one a element containing multiple URLs separated by br elements. Clicking any of the URLs takes you to the same issue.

We recently changed from 3 to 4 and I strongly agree with this comment. I liked the markup system very much. If the new version were truly WYSIWYG I could live with it. Instead, there seems to be a lot of invisible formatting that kills my workflow.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Organizing your space just got easier - Page Tree Drag & Drop is here

Hi Community! I’m Elaine, Confluence Product Manager. You may have read my earlier post about page tree in space navigation sidebar. I'm excited to share another improvement that helps you organize ...

62 views 3 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you