Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,459,868
Community Members
 
Community Events
176
Community Groups

Confluence user session time on Docker

We use https://hub.docker.com/r/atlassian/confluence-server and that is fine.

 

But the session time for users are too short, we used to change according to: https://confluence.atlassian.com/confkb/how-to-adjust-the-session-timeout-for-confluence-126910597.html

 

<session-config>
       <session-timeout>600</session-timeout>
       <tracking-mode>COOKIE</tracking-mode>
   </session-config>
It seems this change is not supported by the docket image? 
I assume that ATL_TOMCAT_CONNECTIONTIMEOUT is not that setting...

2 answers

1 accepted

0 votes
Answer accepted

Hi @Normann P_ Nielsen _Netic_ 
I hope you are well.

To extend the session timeout you need to change the 3 files suggested on the KB you mentioned -- https://confluence.atlassian.com/confkb/how-to-adjust-the-session-timeout-for-confluence-126910597.html

On Docker, you can copy the current file and modify them locally with the needed values.

Then you can mount these individual files, similar to the following command:

docker run (...) \
-v <host-path>/tomcat-web.xml:/opt/atlassian/confluence/conf/web.xml \
-v <host-path>/confluence-web.xml:/opt/atlassian/confluence/confluence/WEB-INF/web.xml \
-v <host-path>/seraph-config.xml.xml:/opt/atlassian/confluence//confluence/WEB-INF/classes/seraph-config.xml \
--name="confluence-staging" -d -p 8090:8090 -p 8091:8091 atlassian/confluence-server:7.13.1

The caveat with it is that, on every upgrade, you need to copy the default files and apply your modification again as using these files from previous versions can introduce problems (in case modifications were applied by the development team).

 

I hope that helps.

Kind regards,
Thiago Masutti

Thanks for the advise; In reallity Im pretty sure only web.xml is needed.

Anyways, due to the caveats I have discarded that currently as an option..

 

But I do hope that the image will support this in the future, the default setting is somewhat low - 1 hour I belive, people are pretty annoyed, as we changed it to 6 hours years ago.

I have accepted the answers; in the term of "nothing rellay smart", just some obvious workarounds with caveats.. 

Hi @Normann P_ Nielsen _Netic_ 

The changes on the seraph-config.xml file are important as it controls the session when the remember me cookie is used.
This is enabled by default on clustered DC, and is optional during form authentication (for Server and DC when SSO isn't used).
See Confluence Cookies for more details

I was about to open a feature, but I realized this is already a setting on the Docker image:

 

  • ATL_AUTOLOGIN_COOKIE_AGE (default: 1209600; two weeks, in seconds)

    The maximum time a user can remain logged-in with 'Remember Me'.

 

Kind regards,
Thiago Masutti

I went for the solution putting a copy of web.xml outside the container, as suggested by Thiago, - to stop users complaining over the short sessiton time.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events