Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Confluence staging environment won't get past login

I created a staging platform for confluence using these instructions (https://confluence.atlassian.com/conf75/create-a-staging-environment-for-upgrading-confluence-1004947887.html) to test the latest update. I've done this before with no problem.

When I go to it, there is the typical login to enter username and password. I enter these and it looks like it's loading, but it just blanks out the page. I know it's recognizing it because if I enter a wrong username of password, I get an error. 

Does anyone know where I can track down what's going on? I don't see anything in catalina.out or catalina.<date>.log.

Thanks,

Chris

4 answers

0 votes

We have encountered the same Problem.

Our solution was to fix the connector settings in server.xml since we used an URI that was not reachable. Since our staging confluence accepted the login, it would redirect to the configured URI, that was not existing.

after we corrected our proxy and DNS settings everything worked fine.

Our production ran under https://confluence.internal.domain. Staging was meant to be at https://confluence-test.internal.domain. Unfortunately "confluence-test" was NXDOMAIN and our Proxy Settings had no host config for confluence-test.

 

hth

My instance of production Confluence is using Crowd, so the staging Confluence will also use Crowd.

It happens that Crowd Application only accept IP address from Production server. 

Try adding the IP address of the Staging to Crowd.

It works for me.

Did you ever find a solution to this?

I get an error msg when im using a wrong password.

But using the correct one, always just reloads the login page, nothing else. Even with the recovery_admin login.

 

/Henrik

Not really, at least not where I could say that I have a solution.

I eventually gave up and just ran the update on the production environment. When there were new updates for both Jira and Confluence, I rsynced -av the environments to the staging server, loaded the current database, and tried again.

This time, neither of the scripts in /opt/atlassian could read /var/atlassian/application-data. I eventually deleted all of the atlassian files, made sure that all directories that they were in had global read and wright privileges, rebuilt the evaluations, and tried again.

That worked. I guess the answer is to trash everything and keep trying until it just works.

0 votes
Shannon Atlassian Team Jul 03, 2020

Hello Chris,

Thank you for raising this with us. Does this happen for all users, or is this the only user on the site?

I would recommend instead of looking at the Catalina.out logs, have a look at the Confluence Server logs and see if you can find any hints about what might be happening.

You can also try to Recover Admin rights and see if that helps you get in.

Let me know how that goes!

Shannon

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
7.5.0
TAGS
Community showcase
Published in Confluence

Confluence Mythbusters: Does Atlassian even use Confluence?

Hi, Confluence collaborators! As part of #Confluence-Collaboratory month, we’ve created a very special Mythsbusters segment, where we're dive into an interesting myth and uncover the truth behind i...

1,368 views 7 28
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you