Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
Level
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Confluence server start error

ddd.png

1 answer

0 votes

Have you looked at why it can't remove the pid file?

Actually though, I think I can guess.  You're going to find it is owned by the wrong user.

I think you have installed Confluence, set to run it as a new user called Conf or Atlassian or Confluence or something like that, then you started it manually while you were logged in as root.  That process then took ownership of a load of files and runs fine until you try to stop it.  The systemctl start command runs Confluence as the non-privileged user who can't delete or edit root's files.

If my guess there is correct, you will need to shutdown confluence completely (you'll need to be root to do it with the scripts, which is the better way to do it, but you could just kill the processes - kill Confluence and Synchrony if they are running).  Then change ownership of all the clobbered files back to the confluence user, in both the confluence installation and data (home) directories, then restart confluence as the confluence user (systemctl will do that)

My installation directory, accessories, database, etc. are all in the "home" directory.My everything is installed in a virtual machine. I copy a new one from the original virtual machine. At this time, I backup the "home" directory of the original virtual machine and replace the "home" directory of the new virtual machine. At this time,the error message shown in the screenshot appears.

I used the command "ps -ef|grep confluence" to make sure that no confluence process was running.

I tried to follow the prompt to switch the confluence user running the startup script, but the same error message is prompted

Can you check the file ownerships?  Are the Confluence home (data) and installation directories and their content all fully owned by the user that will be running Confluence?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

⚡️NEW Group for Confluence Cloud Admins

Calling all Confluence Cloud Admins!  We created a new Community Group to support your unique needs as Confluence admins. This is a group where you can ask questions, access resou...

196 views 3 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you