Confluence search doesn't find german 'Umlaute'

Hi,

we are running a confluence server on ubuntu 16.04. Ubuntu's laguage settings are set to English (en) but confluence index language is set to german.

If I search the german word 'Verlängerung' the search term 'Verlän*' doesn't work. If I use 'Verl?n*' pages and attachments with 'Verlängerung' are found.

Are there any options I miss ?

 

Thx

Jürgen

1 answer

Small correction. Umlaute only don't work if using wildcards. Looking for 'Verlängerung' works but 'Verläng*' doesn't work.

One interesting thing. If I search for 'Jür*' here in answers it works. What is different ? 

Andreas Wurm Community Champion Aug 08, 2017

We've got a similar issue when the summary of a Service Desk ticket incluedes an Umlaut, the auto-search of the knowledge base fails. I'm currently investigating this but do not have a solution yet. If the issue still exists on your instance, I can keep you updated if you want.

See: https://community.atlassian.com/t5/JIRA-questions/German-umlauts-causing-troubles/qaq-p/604766#M201107

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Mar 12, 2019 in Confluence

Confluence Admin Certification now $150 for Community Members

More and more people are building their careers with Atlassian, and we want you to be at the front of this wave! Important Dates Start the Certification Prep Course by 2 April 2019 Take your e...

1,049 views 2 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you