Confluence not starting

Hi

On the server that Confluence is installed on there is another Confluence (2 Confluence Installs) install but they are completely seperate (databases, port numbers etc). We stopped our Confluence install (Confluence 1) as there was no memory available at the time for it to run but the server has since had its memory increased to a sufficient level to allow it to run.

However when we try to start Confluence (Confluence 1) now it appears to start in the logs but then shuts itself down a few seconds later. The other Confluence (Confluence 2) install on the machine seems unaffected and is running fine.

By the looks of the logs, the one that is offline (Confluence 1), used to be configured to connect to our JIRA install but i think that has been removed. Could that be the cause of the problem, and if so is there anyway to fix it without a re-install of Confluence (Confluence 1)?

I think it is Confluence version 4.2 but not 100% sure

6 answers

1 accepted

This widget could not be displayed.

Turned out to be the server ports that for some reason where both set to 8000 rather than the custom values i set for them.

Once i changed them to what they should have been set to by the installer they both started back up again without problems.

Thank you to everyone for all your help

This widget could not be displayed.

Hi Adam,

Found the following from your logs.

2012-06-18 11:33:15,527 ERROR [main] [atlassian.config.bootstrap.DefaultAtlassianBootstrapManager] getMySQLDatabaseName There was an error finding your database name.
2012-06-18 11:33:15,527 ERROR [main] [atlassian.config.bootstrap.DefaultAtlassianBootstrapManager] checkMySQLStorageEngineType Your database Storage Engine could not be determined. Using the MyISAM engine can result in data integrity issues.Please see http://confluence.atlassian.com/x/voTcDQ for more information.

It seems that your database in MySQL is still using MyISAM storage engine, please change to InnoDB and check whether it works. For more information please refer to the following.
* http://confluence.atlassian.com/x/voTcDQ

Cheers,
Josua

Yep,

Stupid me, missed it completely

As hopeful as i was that this was all it was, i have checked the database and all the tables are InnoDB. No MyISAM in sight!

hmm may be your installation is corrupt ??

as a last resort why not download a standalone distribution of the same version your are running which i gather is Confluence 4.1 and use a different home directory(copy what is required) and use a copy of your schema 'web93confluence' and try this out?

This widget could not be displayed.

Is there any specific message in the logs? Are you sure that the listen and shutdown port do not collide?

Edit: I noticed you're using home D:\Application Data\Confluence, what home directory are you using for the other confluence install?

The other is D:\Application Data\KGNConfluence

This widget could not be displayed.

Thanks for the logs

something that stands out for me

2012-06-18 11:35:32,402 WARN [main] [atlassian.plugin.webresource.DefaultResourceDependencyResolver] resolveDependencies Cannot find web resource module for: com.atlassian.jira.gadgets:common
2012-06-18 11:35:35,569 WARN [main] [atlassian.config.xml.AbstractDom4jXmlConfigurationPersister] saveDocumentAtomically Unable to move D:\Application Data\Confluence\confluence.cfg.xml3257076768419523368tmp to D:\Application Data\Confluence\confluence.cfg.xml. Falling back to non-atomic overwrite.
2012-06-18 11:35:35,569 INFO [main] [confluence.upgrade.impl.DefaultUpgradeGate] waitForBooleanValue Waiting to find if plugin dependent upgrades are required. Maximum wait time will be 90 seconds.
2012-06-18 11:35:35,569 INFO [main] [confluence.upgrade.impl.DefaultUpgradeGate] waitForBooleanValue plugin dependent upgrades are required : false.

Looks like its hitting some sort of permissions issues when it creates a temporory config file and then tries to replace the one in place with the temporary one.

check who ever is logged on to start/stop confluence has the appropriate permissions over these files

D:\Application Data\Confluence

and all files under that directory, i'm assuming that this is where your confluence.home is reffering to from your logs.

check and make sure user you are using to start/stop confluence has required permissions to bind confluence to these ports and last since this is windows, check and see if your antivirus applications are not messing with your start up.

Restart of the machine or of confluence at that point?

Account that was starting and stopping at the time i think is either the root administrator account (if it uses logged on user) or the default for the service which might be the SYSTEM account? so i dont think permissions are an issue, plus it has previously started without issue and no permission changes have been done to that area.

As above, has previously started so user has permissions to bind ports.

Anti-Virus is set to exclude that entire folder and all under it except uploads folder.

Just Confluence should be enough.


Delete all files and folders inside

<confluence-home>/bundled-plugins
<confluence-home>/plugin-cache
<confluence-home>/plugins-osgi-cache
<confluence-home>/plugins-temp
<confluence-home>/bundled-plugins_language

<tomcat_home>/temp
<tomcat_home>/work

and do a restart and see how it goes

This being windows i'm not sure if the ports have been freed up properly

do a ‘netstat –an’ and see if any of the port you rely on is still in use and find and kill if its in use.

Don’t have to restart the machine, just check your task manager to ensure there is no rouge java process running which you are not aware of and should not be running

Okay, will give that a go later. Will backup the files first though since im not sure what is in there and whether it will re-generate or not.

The Atlassian log analyser suggested the same thing about the ports, it said it found that it couldnt bind the port. I also looked through the links suggested by Hercules about the ports and ran netstat -an as suggested but both the web port and control ports where not in use

I checked task manager but couldnt find any java.exe processes, there was two tomcat6 processes which was expected, JIRA and the other Confluence install.

See my previous answer, there are two ports you need to change in your conf/server.xml: your listening and shutdown port. Be sure that both do not collide.

The netstat-an shows them as both not being in use and there has been nothing added to the server that would use those ports. It has previously started using them so unless the configuration has got corrupted somehow they shouldnt have changed.

Can you please upload the conf/server.xml of both servers? If we can't fix this in a timely matter, I recommend to log a ticket at https://support.atlassian.com instead. Cheers :)

(Non Starting Confluence Server.txt) - This is from the one that i cant get to start, i have removed the hostname but it is set to its web address

(Second Confluence Server.txt) - This is from the one that is running, i have removed the hostname but it is set to localhost

I have also logged a ticket with Atlassian support but cross posted to here when given the option to

Both files changed to .txt from .xml to allow upload

I chose custom ports option because i wanted a clear range.

It has previously worked with those port numbers too. I will try restarting the machine when it is clear to see if that releases the ports.

Adam, from the server.xml that you provided, seems like there's something weird with the port assignment. Normally we don't really assign to that big number of port and I am suspecting that the port was reserved somehow that's why you couldn't bind it. Could you please try to bind lower port and check whether it works? Cheers! :)

I have restarted the server and JIRA and our second Confluence install have started fine and are accessible.

The Confluence install that has the problem looks to have stalled during its start up and is using about half the memory load of the fully running Confluence install.

I will keep an eye on it and see if it finishes loading

The serivce hung whilst starting. So i used task manager to kill it and then re-started it.

It seemed to be going okay but then has disappeared from the task list again and seemed to stop staring with the same error about binding to port.

Is there a way to change the port number without a re-install, im guessing i need to change the web port and the control port?

This widget could not be displayed.

Could you please give us more information and a copy of the log?

I don’t see a reason why it should shut down automatically because JIRA that was available to authenticate is unavailable

I might be wrong but logs will show us information on that

This widget could not be displayed.

I couldn't see anything in the logs that stood out but i am still new to it so not sure what to look for.

JIRA is available still but the link is removed thats all.

(atlassian-confluence.log)

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

509 views 7 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you