Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,413
Community Members
 
Community Events
176
Community Groups

Confluence not accessible with nginx reverse proxy

Edited

I've set up confluence as a docker on my Unraid machine and would like to make it accessible from the outside of my LAN Network by using a reverse proxy.

For that I use Nginx Reverse Proxy Manager, which worked out perfectly for all my applications so far.

I set up my CNAME record in Cloudflare, which points to the A record of my domain, which points directly to my IP adress.

When I enter the domain (confluence.mydomain.tld) in Firefox I get an 502 (bad gateway) from Cloudflare, which should mean, that the redirection works fine, but the confluence docker is not responding to back.

I saw a thread with a similar issue to mine, but that config does not work for me.


Also while using this config, Confluence displays the following error on it's homepage:

Tomcat config is incorrect
The Tomcat server.xml has an incorrect configuration:

scheme should be 'http'
proxyName should be '10.10.50.15'
proxyPort should be '8090'

In the attachments you can see my settings in confluence, nginx proxy manager as well as the confluence docker itself in unraid.

I think there's probably an issue between the proxy manager and confluence, so my guess is, that I have something misconfigured

 

confluence custom paths.PNGconfluence path.PNGconfluence ssl settings.PNGConfluence Docker Settings.PNGConfluence Genral configuration.PNG

 

2 answers

Guys, put this in Custom Nginx Configuration:


 location / {
client_max_body_size 100m;
proxy_set_header X-Forwarded-Host $host;
proxy_set_header X-Forwarded-Server $host;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_pass http://192.168.1.4:8090;
}
location /synchrony {
proxy_set_header X-Forwarded-Host $host;
proxy_set_header X-Forwarded-Server $host;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_pass http://192.168.1.4:8091/synchrony;
proxy_http_version 1.1;
proxy_set_header Upgrade $http_upgrade;
proxy_set_header Connection "Upgrade";
}

Where 192.168.1.4 = your local ip of confluence instance. 

Also:

The cloudflare proxy does not actually follow the redirect nginx sends, which results in this error. You probably need to set the SSL/TLS encryption mode to Full or Full (Strict) or remove the additional CloudFlare proxy.

Did you ever figure this one out?  I'm also getting 502 errors when trying to use Nginx Proxy Manager with Confluence running on my local network.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
7.9.1
TAGS

Atlassian Community Events