Confluence mention returns zero users

Confluence Mention worked at one point, but it stopped working all of the sudden.


When I start typing something like @Eldon, the User suggestions shows "No user found".

This used to work. I have tasks that were created to me this way.

We've tried to Rebuilding the Index (Confluence Admin --> Administration --> Content Indexing --> Search indexes --> Rebuild), but no luck.

I've also made sure that "Notify watchers" is checked by default when I'm editing a page. (This was a solution to someone else's problem here on Answers.

Does anyone know what's going on?

2 answers

1 accepted

This widget could not be displayed.

We found the solution while trying to fix another problem. There was a bug in the Confluence version we were using. I believe we were on Confluence 5.4.0. It had problems communicating with our AD server through Crowd. Upgrading Confluence fixed this problem.

Hey Eldon, where did you find the bug? We have the same problem for one of our users. Could you please add the related ticket to your answer? Thank you!

Sorry Csaba. I can't find the issue... I've been trying to dig for it in my emails, but can't find it. We had a call with Atlassian to figure this out. They are aware of the problem. We upgraded to Confluence 5.4.4 and it has been fixed. Sorry can't help more.

This widget could not be displayed.

Hi Eldon,

Just to let you know, Confluence metion issue is usually related to indexing. You got it right by rebuilding index.

However, since rebuilding index from Confluence Admin page doesn't fix the issue, you might want to try to rebuild Confluence index from scratch.

To remove the index and rebuild it from scratch:

  1. Shut down Confluence server.
  2. If these folders exist, make a backup of them, as their contents cannot be rebuilt:
    1. <confluence-home>/index/plugin - this is where the Usage Tracking plugin stores the usage statistics.
    2. <confluence-home>/index/edge - this is where the index of Likes and Popular Content are stored.
  3. Remove the <confluence-home>/index directory.
  4. If you made a backup of the folders in Step 2, create <confluence-home>/index, and copy the backups in to it.
  5. Restart Confluence.
  6. If restarting Confluence doesn't trigger the re-index task (troubleshooting issue in the same Confluence version), perform manual index rebuilding as described in Content Index Administration.

Hope this information helps.

Kind Regards,

Amrta Faruqi

Hi Amrta,

Unfortunately, this didn't seem to fix it.

We gzip'd both plugin and edge, removed index, then recreated it and put plugin and edge back in. Started up Confluence again. When we opened up Confluence on our browser, we saw that the recent updates was not populated. Went to the Search Indexes saw that it was 0% built. So hit the Build button. After the Search Index got to 100%, saw recent updates populated correctly. But then tried to @mention someone... still no users show up.

Also, when we started Confluence, we were keeping an eye on catalina.out. We didn't seem to see anything useful in there. Even when we hit Build, it didn't notify us that it was building the search index. Is there another (more useful) log that we can look at?

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

496 views 7 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you