• Community
  • Products
  • Confluence
  • Questions
  • Confluence logs: "[confluence.content.transform.ContentTransformationContext] getStack No request found. Need request to store the context stack."

Confluence logs: "[confluence.content.transform.ContentTransformationContext] getStack No request found. Need request to store the context stack."

I can see the following log entries very frequently in our confluence log:

2016-01-06 10:06:41,380 WARN [StreamsCompletionService::thread-54] [confluence.content.transform.ContentTransformationContext] getStack No request found. Need request to store the context stack.
-- url: /confluence/plugins/servlet/streams | userName: <user>

As far as I can tell it does not occur for all users on our Confluence instance, at least there are only a few usernames that appear in the latest log file.

I am unsure whether this has any effect on Confluence or usage - I haven't had any error reports from users, just trying to figure out what is going on.

Has anyone experienced this, or know what the cause is?

Our Confluence instance uses the JIRA user directory.

5 answers

This widget could not be displayed.

is there an solution for this issue?

Ann Worley Atlassian Team Nov 21, 2017

Hi Ricardo,

I found a couple of support tickets where the error, "No request found. Need request to store the context stack." was reported. Each instance had a different URL in the log as the URL that was being accessed. There were no cases with a clear explanation of the error and no cases with recent versions of Confluence. Plugins seemed to be the suspected culprits in the cases I reviewed.

If the URL in your error messages is similar to what was first posted in this thread, "/confluence/plugins/servlet/streams",  then a good first step would be to clear the Confluence plugins cache as described in How to clear Confluence plugins cache

In the meantime, to help me narrow down the issue, please let me know:

  • What version of Confluence are you seeing the error in?
  • What database type is Confluence using, PostgreSQL, MySQL, Oracle, MS SQL?
  • An example of the complete error message (please redact anything confidential) 
  • What user-installed plugins are installed?
  • Are there any performance or functionality issues associated with the errors?
  • Do you see the error in both Production and Test/Staging environments?

I look forward to hearing more about the issue. If clearing the plugin cache fixes it please post back to this thread so people who search for the error can find the solution in the future.

Thanks,

Ann

Hi Ann,

thank you for the reply.

Clear the Plugins cache unfortanly don't work. The Warn message still appear. Here an example.

2017-11-29 10:00:40,886 WARN [StreamsCompletionService::thread-29280] [confluence.content.transform.ContentTransformationContext] getStack No request found. Need request to store the context stack. -- url: /plugins/servlet/streams | referer: https://##############/plugins/servlet/gadgets/ifr?container=atlassian&mid=2841145769984&country=DE&lang=de&view=default&view-params=%7B%22writable%22%3A%22false%22%7D&st=atlassian%3ARO6dWLFKwEDad6UwFmRCP577OQdZA7%2BsiD1VkLC7HTop3DJ6RbCIcsyD1IJ25cBx54BhTVhs0fEzmb2sr%2FMHGqPkBzryTfykwwddrqod3sqTFdWDD7Wh7bDrpl5W%2FmO8VXrrI8bRGaTusq8RIkgVQwcoMvIXKkp8tnTGvy12G2PAB6I872dJufcpvKwDYMlfm2x7lpZtn1fTW3J%2BO%2BGUzSmJntYRyHmorh9MEsfJsL%2FT1AwPJmRfO48hBedBxwRsrTmsdK%2BzH4T%2Bm6a%2FdlLhkeGqtSZNNEirn1zr70uEUDGuFG2pOe%2Buh7E9%2BL%2BipJtdGwDZjPLKBlB2uVqgfXvGDJSAtBEet7YfzJ9uKyTZsBo2ANlI&up_isConfigured=true&up_isReallyConfigured=false&up_title=Aktivit%C3%A4tsstrom&up_titleRequired=true&up_numofentries=10&up_refresh=false&up_maxProviderLabelCharacters=50&up_rules=&up_renderingContext=&up_keys=&up_itemKeys=&up_username=&url=https%3A%2F%2F#########%2Frest%2Fgadgets%2F1.0%2Fg%2Fcom.atlassian.streams.confluence%3Aactivitystream-gadget%2Fgadgets%2Fconf-activitystream-gadget.xml&libs=auth-refresh | traceId: e5c99eaa6c440aa7 | userName: ########

######## = URL or Username

  • Confluence version 6.3.3
  • We are using an Oracle Database
  • We using RefinedTheme, Scroll, Enterprise News Bundle, Comala Workflows and more but from the message it seems that the activitystream of confluence have this issue
  • I don't think that the performance are affected but in 5 minutes of work about 100 warn message as above appear
  • No we only have the warn message in the production enviroment

Thanks and regards

Ricardo

Hi Ricardo,

I ran across this same issue in a case today and found that this appears to be log spam from the Scroll macro: https://k15t.jira.com/browse/VSN-3576

I would recommend trying the workaround listed at the link above from k15t:

Add new entry "com.k15t.scroll.runtime.confluence.content.transform.ContentTransformationContext" to "Logging and Profiling" with the log level "ERROR"

Please report back and let us know whether this helps.

Thanks!

Justin

This widget could not be displayed.

We also see the same error and don't know what it relates to or what effect it has.

This widget could not be displayed.

We use Crowd instead of JIRA user directory and our log is full of these entries. We this since the update to Confluence 5.8.

Anyone has a solution for that?

This widget could not be displayed.

I just experienced this issue while adding the JIRA Agile Wallboard gadget to a Confluence page.

Confluence v6.9.0

JIRA v7.9.2#79002-sha1:3bb15b6

WARN [StreamsCompletionService::thread-205] [confluence.content.transform.ContentTransformationContext] getStack No request found. Need request to store the context stack.
-- url: /confluence/plugins/servlet/streams

This widget could not be displayed.

Hi everyone,

 

I also get the same error in my Confluence 6.1.4 instance and stumbled across the reason why by chance. I'm able to reproduce it. I get the follwoing WARN message in Confluence

WARN [StreamsCompletionService::thread-46] [confluence.content.transform.ContentTransformationContext] getStack No request found. Need request to store the context stack.
-- url: /plugins/servlet/streams | ... | userName: xxx

if in my Jira 7.4.2 instance an activity gadget is added to my dashboard. In that gadget you must tick the Confluence stream out of the Available streams list (which is default). Then JIRA loads the Confluence Activity as well which then causes the error and actually leaves 6 WARN messages everytime you refresh the gadget.

Hi everyone,

I solved my problems with these errors. I encountered another situation where a very similar error message would appear. When ever I loaded a page containing a Page Properties Report I got a very similar error trying to connect to 

-- url: /rest/masterdetail/1.0/detailssummary/lines

Even more weird was, that this error occured for users that were on holidays an thus definately not logged in. At first I thought the particular user programmed a REST-call to retrieve information from one of our pages but soon found out that there must have been a thread being stuck calling the same page over and over again. Causing about 60 error messages per hour. 

It came down to, that the Page Properties Report was causing basically one error message per element of the report. I found this ticket regarding on of our K15T add-ons: https://k15t.jira.com/browse/VSN-3576 and thought I should give it a shot to update to the newest version. 

And that actually solved both of the problems at once (so far). Initial requests don't reproduce the error anymore so I'm hoping it solved it once an for all.

Hope that helps in your cases as well. Would be interested if that applies to your instances too.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

459 views 6 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you