It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Confluence : issue with Anchor links hidden by breadcrumb navigation bar Edited

Hello, I’m running Confluence server 7.0.1 and I noticed an issue with Anchor links.

When clicking on a link pointing to an anchor (on the same page or on another page), the first lines where the anchor was set are hidden behind the breadcrumb navigation bar.

 

So we have the impression that the anchor link does not point to the exact position where it was set, but to the second or third line below.

This is often confusing when pointing to titles or sections, because we don’t know where we were pointed to because we cannot read the title.

 

However when scrolling once down and up again, the breadcrumb navigation bar disapears and we can finally see the lines that were hidden before.

And they correspond to the place / title where the anchor was set, so we know the link works properly.

 

Is there any tips on how to solve this ?

Thank you in advance.

 

Example when clicking on a link to an anchor (Title where anchor is set is not visible) :

image.png

When scrolling once up then once down, breadcrumb navigation bar disapears and title can be seen :

image.png

 

Also, if the link and anchor are on the same page I noticed this issue only occurs when the anchor is located somewhere above the link (which is most of the time in my case).

If anchor is located somewhere below the link, the breadcrumb navigation bar dissapears by default so all the text is correctly visible.

 

The issue is even more annoying when pointing from another page to the anchor. In that case, it seems the global menu bar hidding the Title where the anchor was set : 

image.png

1 answer

[EDIT] added more description in content of ticket instead of this answer

I have the same problem and would appreciate a quick fix.

Sigh, exactly this, what is this, it is sooooooo frustrating that something like this doesn't work as intended.

But yeah, any fixes incoming on this?

@Adrien , I'd like to follow this. Please could you post a link to the ticket.

b_mort I'm New Here Jun 17, 2020

Just came across this very issue and a quick search brought me here- would love a quick fix or work around to this as well! 

+ 1 vote. Very frustrating.

A very hacky workaround is to put a line break for every header (or anchor title) in your page. That way it does work as the anchor goes to the empty line which is hidden by the page header and then you can see the anchor title just below it.

As I said very hacky but works. I can't believe this is not bothering Atlassian :)

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

Lessons and Learnings: Six Months of Working Remote [Discussion]

Hey there, folks! For most of us, the past six months- yes, you read that right- have been a journey. More people than ever before have pivoted to working remotely, and navigating being on-scre...

5,345 views 4 6
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you