Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,457,048
Community Members
 
Community Events
176
Community Groups

Confluence has been failing to save pages on multiple attempts, timing out.

Confluence has been failing to save pages on multiple attempts, timing out.

2 answers

1 accepted

0 votes
Answer accepted

Under General Configuration - Collaborative Editing, check the Synchrony service to see if it is running.

I had the same issue, and the service had failed.

I ended up upping the memory for it from 2GB to 4GB and it has been working fine since.

Change will take affect on next restart of Confluence.

  1. Stop Confluence.
    1. To do that, open up a terminal window and browse your way to the Confluence-Installation-Directory/bin folder.
    2. Inside this very same folder, run the following command: ./stop-confluence.sh
    3. Just consult with your team first to understand if this is the script usually used or if you have customized a different one based upon your needs. If this is the case, run the customized one.
  2. Now that we stopped Confluence, under the same Confluence-Installation-Directory/bin folder, look for a file called setenv.sh.
    1. Open this file.
    2. Search for synchrony.memory.max. If you have this setup, just change its value to an appropriate allocation.
    3. If you don't have this setup, it means that the default Heap Allocation for Synchrony was applied, which, in this case, is 2GB for versions above 7.10 and 1GB for versions below it. We need to add the parameter to change the Heap Allocation. The example below sets it to 2GB, change the number to allocate as many GB's as you may need to.
       CATALINA_OPTS="-Dsynchrony.memory.max=2g ${CATALINA_OPTS}"
  3. With that done, still inside Confluence-Installation-Directory/bin, run the ./start-confluence.sh script. Don't forget to consult with your team to understand if you have customized scripts or not. In case you do, run your customized one. In case you don't, run the mentioned one.
  4. Confluence will come up with Synchrony having the new allocated Heap.
0 votes
Brant Schroeder Community Leader Aug 04, 2022

@Haroon Habibi  Have you tried using a different browser? Have you tried clearing your cache?

Yes I have done all that,

I have tried reloading the page, trying to select different areas of the page to comment on, clicking slower and waiting for icons to load
I think a lot of other people hit the same issue, and they tend to make comments at the end of the page instead of inline, which is far more difficult to review

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events