Confluence hangs at start up

I was evaluating Confluence and I was able to get it up and running correctly; however as always happen I had to leave it "alone" for a while.

Today I was trying to restart it but it simply hang at this point:

16-Mar-2017 10:12:34.675 WARNING [main] org.apache.tomcat.util.digester.SetPropertiesRule.begin [SetPropertiesRule]{Server} Setting property 'debug' to '0' did not find a matching property.
16-Mar-2017 10:12:35.006 WARNING [main] org.apache.catalina.startup.SetAllPropertiesRule.begin [SetAllPropertiesRule]{Server/Service/Connector} Setting property 'debug' to '0' did not find a matching property.
16-Mar-2017 10:12:35.062 WARNING [main] org.apache.tomcat.util.digester.SetPropertiesRule.begin [SetPropertiesRule]{Server/Service/Engine} Setting property 'debug' to '0' did not find a matching property.
16-Mar-2017 10:12:35.110 WARNING [main] org.apache.tomcat.util.digester.SetPropertiesRule.begin [SetPropertiesRule]{Server/Service/Engine/Host} Setting property 'debug' to '0' did not find a matching property.
16-Mar-2017 10:12:35.386 WARNING [main] org.apache.tomcat.util.digester.SetPropertiesRule.begin [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'debug' to '0' did not find a matching property.
16-Mar-2017 10:12:37.408 INFO [main] org.apache.coyote.AbstractProtocol.init Initializing ProtocolHandler ["http-nio-8090"]
16-Mar-2017 10:12:37.509 INFO [main] org.apache.tomcat.util.net.NioSelectorPool.getSharedSelector Using a shared selector for servlet write/read
16-Mar-2017 10:12:37.520 INFO [main] org.apache.catalina.startup.Catalina.load Initialization processed in 3524 ms
16-Mar-2017 10:12:37.552 INFO [main] org.apache.catalina.core.StandardService.startInternal Starting service Tomcat-Standalone
16-Mar-2017 10:12:37.553 INFO [main] org.apache.catalina.core.StandardEngine.startInternal Starting Servlet Engine: Apache Tomcat/8.0.39
2017-03-16 10:12:41,572 INFO [localhost-startStop-1] [com.atlassian.confluence.lifecycle] contextInitialized Starting Confluence 6.0.4 [build 7102 based on commit hash d2664877b

 

As I was using the trial license it may well be that it is expired (should not based on date) but in that case I would expect to see a warning...

What I could do to get more info and resolve this? At least I would like to been able to extract the test data I was inserting into H2 database...

 

Regards Claudio

1 answer

1 accepted

0 votes
Accepted answer

Information in the log is not sufficient for troubleshooting. I'd recommend you to take a look at https://confluence.atlassian.com/confkb/how-to-check-the-confluence-application-is-running-830153179.html and perform further troubleshooting steps smile

Hi Saleh,

Thank you for the pointer I will keep at hand for next time smile 
For whatever reason today the server started up with no problem ... no idea what was the issue was as nothing has been changed (beside a shutdown and restart overnight). 

I will accept your answer as I think is the right path to go to test everything and to provide more information for debugging.

Thank you very much for your help

Glad to hear that it's working now Claudio smile 

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

1,031 views 15 13
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you