It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Confluence fails to run

Hello,

I have i selfthosted Confluence server running on a Windows Server 2019.

I run the server on CMD.

 

For some reason the server restarted, and now the Confluence server fails to start correctly.

 

When i try to start the Confluence server, i am met with the following error:

17-Jan-2020 10:33:10.113 INFO [http-nio-8090-exec-6] org.apache.coyote.http11.Http11Processor.service Error parsing HTTP request header
Note: further occurrences of HTTP request parsing errors will be logged at DEBUG level.
java.lang.IllegalArgumentException: Invalid character found in method name. HTTP method names must be tokens
at org.apache.coyote.http11.Http11InputBuffer.parseRequestLine(Http11InputBuffer.java:415)
at org.apache.coyote.http11.Http11Processor.service(Http11Processor.java:294)
at org.apache.coyote.AbstractProcessorLight.process(AbstractProcessorLight.java:66)
at org.apache.coyote.AbstractProtocol$ConnectionHandler.process(AbstractProtocol.java:853)
at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1587)
at org.apache.tomcat.util.net.SocketProcessorBase.run(SocketProcessorBase.java:49)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
at java.lang.Thread.run(Thread.java:748)

 

Has anybody seen similar issues?

 

 

2 answers

1 accepted

0 votes
Answer accepted

changed the setting to "Allow connections from other computers", but it did not improve the situation. The Confluence server still fails with the same error message as above - any ideas?

Sounds like you have some kind of typo in a config file. Maybe server.xml.

Hi Dave thanks for your reply.

I have been looking at our Conf files including server.xml, and cant seem to find any issues.

The strange thing is that Confluence has been up and running, but after Windows restarted during a update, Confluence now fails to start.

 

The installed updated was the two shown below.

2020-01-20 10_57_57-management - Remote Desktop Connection Manager v2.7.png

Is it possible that these could cause issues?

I think you're barking up the wrong tree looking at Windows updates.  Are you running a supported version of Java? How are you defining which Java will run? Maybe download Confluence fresh from Atlassian and drop in the unedited server.xml and see if it starts.

Confluence only reads most of its config files as it starts up.  In the case you describe, it probably means it started up ok last time, then someone edited a config file and inserted an error of some form which it is only seeing now you're trying to start it again.

This is a TRIAL installation of Confluence. Unfortunately, we have spent several weeks populating and customizing the installation in order to make a Demo for decision makers. It was working perfectly, and no changes were made to the server. After a windows restart (in connection with windows update) it no longer worked.

I have replaced server.xml with a version from a fresh install (using default values), but that did not solve the issue. Confluence is still not able to connect to the h2db.

You might have a bigger problem here.  It could be that your restart corrupted the h2 database (this can happen if you don't completely stop Confluence properly before restarting Windows). 

Hopefully, it's something else.  Could you read the log file to see what other errors you are getting as it starts up?

Digging further, I might have stumbled upon the issue, but have no idea how to fix it.

As the error stated that it was not possible to connect to the h2 database, I followed Atlassian documentation, in order to connect to it directly, using the browser, in order to verify that the connection could actually be made.

On the server where Confluence is installed, I get the following message:

"Sorry, remote connections ('webAllowOthers') are disabled on this server."

The strange thing is that if I connect from my local laptop, I get the H2 console.

Somehow, the confluence server think that it is coming from the outside when it connects to the database?

How do I change the setting 'webAllowOthers' so it can connect to its own database again?

Below is the error message from the console.

Um, that setting is not in Confluence at all.

You'll need to run the database tool on the server.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

Lessons and Learnings: Six Months of Working Remote [Discussion]

Hey there, folks! For most of us, the past six months- yes, you read that right- have been a journey. More people than ever before have pivoted to working remotely, and navigating being on-scre...

8,501 views 6 6
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you