Confluence database setup on SQL server 2008 hangs

Hi everybody,

When I run the dbsetup after a seemingly successful installation, setup hangs after "Next" in the diver configuration browser screen and never finishes.

Confluence version is 5.6 on Windows 2008, installed as a service, using SQL Server 2008 and the supplied jtds driver.

Already checked Database parameters, running the service with a dedicated user, checked folder permissions, but haven't been able to complete database setup.

Database doesn't get any table created.

Any help will be much appreciated.

Miguel.

The last lines of atlassian-confluence.log are:

2014-10-09 13:37:50,749 INFO [localhost-startStop-1] [com.atlassian.confluence.lifecycle] contextInitialized Starting Confluence 5.6 [build 5634 based on commit hash 4ea7654ffdbf0eeae188b65561dfce6e40887ccf]
2014-10-09 13:37:53,013 WARN [localhost-startStop-1] [atlassian.config.xml.AbstractDom4jXmlConfigurationPersister] saveDocumentAtomically Unable to move C:\Program Files\Atlassian\Application Data\Confluence\confluence.cfg.xml2435876119779243338tmp to C:\Program Files\Atlassian\Application Data\Confluence\confluence.cfg.xml. Falling back to non-atomic overwrite.
2014-10-09 13:37:53,434 INFO [localhost-startStop-1] [atlassian.plugin.manager.DefaultPluginManager] earlyStartup Plugin system earlyStartup begun
2014-10-09 13:37:56,575 INFO [localhost-startStop-1] [atlassian.plugin.manager.DefaultPluginManager] earlyStartup Plugin system earlyStartup finished in 0:00:03.138
2014-10-09 13:37:56,577 INFO [localhost-startStop-1] [atlassian.plugin.manager.DefaultPluginManager] lateStartup Plugin system lateStartup begun
2014-10-09 13:37:57,962 INFO [localhost-startStop-1] [atlassian.plugin.manager.DefaultPluginManager] lateStartup Plugin system lateStartup finished in 0:00:01.385
2014-10-09 13:37:58,840 INFO [localhost-startStop-1] [com.atlassian.confluence.lifecycle] init Confluence is ready to serve
2014-10-09 13:38:20,472 INFO [http-bio-8090-exec-6] [springframework.web.context.ContextLoader] initWebApplicationContext Root WebApplicationContext: initialization started
2014-10-09 13:38:33,100 INFO [http-bio-8090-exec-6] [com.atlassian.confluence.lifecycle] <init> Loading EhCache cache manager
2014-10-09 13:38:39,305 WARN [http-bio-8090-exec-6] [org.springframework.beans.TypeConverterDelegate] findDefaultEditor PropertyEditor [com.sun.beans.editors.EnumEditor] found through deprecated global PropertyEditorManager fallback - consider using a more isolated form of registration, e.g. on the BeanWrapper/BeanFactory!
 -- referer: http://<server>:8090/setup/setupstandarddb-start.action?database=mssql | url: /setup/setupstandarddb.action | userName: anonymous | action: setupstandarddb
2014-10-09 13:38:42,083 WARN [http-bio-8090-exec-6] [render.xhtml.migration.PageTemplateSiteMigrator] calculateNumberOfMigrationThreads SQL Server detected so only one thread will be used in migration to avoid dead lock problems.
 -- referer: http://<server>:8090/setup/setupstandarddb-start.action?database=mssql | url: /setup/setupstandarddb.action | userName: anonymous | action: setupstandarddb
2014-10-09 13:38:42,282 WARN [http-bio-8090-exec-6] [render.xhtml.migration.DefaultSiteMigrator] getNumberOfThreads SQL Server detected so only one thread will be used in migration to avoid dead lock problems.
 -- referer: http://<server>:8090/setup/setupstandarddb-start.action?database=mssql | url: /setup/setupstandarddb.action | userName: anonymous | action: setupstandarddb
2014-10-09 13:38:42,306 WARN [http-bio-8090-exec-6] [render.xhtml.migration.PageTemplateSiteMigrator] calculateNumberOfMigrationThreads SQL Server detected so only one thread will be used in migration to avoid dead lock problems.
 -- referer: http://<server>:8090/setup/setupstandarddb-start.action?database=mssql | url: /setup/setupstandarddb.action | userName: anonymous | action: setupstandarddb
2014-10-09 13:38:45,090 WARN [http-bio-8090-exec-6] [render.xhtml.migration.DefaultSiteMigrator] getNumberOfThreads SQL Server detected so only one thread will be used in migration to avoid dead lock problems.
 -- referer: http://<server>:8090/setup/setupstandarddb-start.action?database=mssql | url: /setup/setupstandarddb.action | userName: anonymous | action: setupstandarddb
2014-10-09 13:38:46,141 WARN [http-bio-8090-exec-6] [render.xhtml.migration.DefaultSiteMigrator] getNumberOfThreads SQL Server detected so only one thread will be used in migration to avoid dead lock problems.
 -- referer: http://<server>:8090/setup/setupstandarddb-start.action?database=mssql | url: /setup/setupstandarddb.action | userName: anonymous | action: setupstandarddb
2014-10-09 13:38:46,154 INFO [http-bio-8090-exec-6] [springframework.web.context.ContextLoader] initWebApplicationContext Root WebApplicationContext: initialization completed in 25680 ms
2014-10-09 13:38:46,426 INFO [http-bio-8090-exec-6] [atlassian.plugin.manager.DefaultPluginManager] shutdown Shutting down the plugin system
2014-10-09 13:38:46,459 INFO [http-bio-8090-exec-6] [atlassian.plugin.manager.DefaultPluginManager] earlyStartup Plugin system earlyStartup begun
2014-10-09 13:38:46,589 WARN [http-bio-8090-exec-6] [osgi.container.felix.ExportsBuilder] getUrlClassPath Cannot deep scan non file 'http://felix.extensions:9/'
 -- referer: http://<server>:8090/setup/setupstandarddb-start.action?database=mssql | url: /setup/setupstandarddb.action | userName: anonymous | action: setupstandarddb
2014-10-09 13:39:01,359 WARN [http-bio-8090-exec-6] [atlassian.soy.renderer.SoyResourceModuleDescriptor] enabled soy-resource is deprecated. Please convert com.atlassian.confluence.plugins.soy:soy-core-functions to a web-resource and/or a soy-function
 -- referer: http://<server>:8090/setup/setupstandarddb-start.action?database=mssql | url: /setup/setupstandarddb.action | userName: anonymous | action: setupstandarddb

3 answers

1 accepted

After several searches and about 4 reinstallations and countless restarts and changes I finally found it.

The problem was solved by adding the parameter -XX:MaxPermSize=128M to the Java options for Tomcat.

Steps:

  1. Find service name for Confluence, someting like "Confluence101014155533" (Check on the service properties, in the Services window)

  2. Open a command line window on the bin folder (C:\Program Files\Atlassian\Confluence\bin or similar)

  3. Run tomcat7w //ES//Confluence101014155533 (Your actual service name)

  4. Add the -XX:MaxPermSize=128M in the Java Options field on the Java tab

  5. Restart the service

Hope it helps.

Is the database user that you've configured in Confluence the db_owner of Confluence database?

Cheers

Hi Tiago, the user was in the db_owner group but was not THE db_owner, I changed that, but it didn't make any difference.

At first check i Roles for DB and what is you config file?

Hi Aleš, roles where ok. but found the solution, thanks anyway

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

385 views 21 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you