Confluence and Synchrony behind IIS8 can't copy or insert larger blocks of text Edited

I've got a Confluence setup running behind an IIS8 proxy doing SSL.  Everything works except for one thing.

When I try to copy a few paragraphs or two of text, attempt to copy a table, or attempt to insert a table larger then about 8x8, the Collaborative Editing fails and the text on the bottom bar goes from "Ready to Go" or "Changes Saved" to "Can't save changes".  It will then sit there until you cancel editing, discard your changes, and reopen the editor.

Copying and Pasting smaller blocks of text or inserting smaller tables works as expected.  There is some kind of threshold around 3,500 characters of text is the difference between working and breaking.

The Environment is Windows 2012 R2 with IIS8 with SSL running and Confluence 6.1.0.  This happens in both IE and Chrome, I have not tested Firefox.  There are no errors in any Confluence logs, IIS8 logs, or even in the developer console in Chrome.

If I turn off the proxy and go to Confluence 6.1.0 directly, everything works fine.  I also have an Apache install doing the same thing and it also works fine.  This problem appears limited to IIS8 doing WebSockets.

My best guess is that there is a setting in IIS8 that is limiting the amount of data it will proxy.  I just can't find that setting.

Settings I've looked at include:

  • Request Filtering
    • Maximum URL Length in Bytes - currently set to 8192 which is twice the default
    • Maximum Query String - currently set to 8192 which is four times the default.
    • Maximum allowed content length - currently set at 30000000 which is the default, equates to 28.6MB and is far larger then what I'm doing.
  • ApplicationHost.config and web.config
    • system.webServer/webSocket - receiveBufferLimit - currently set to 4194304 which is the default and equates to 4MB, also larger then what I'm doing.

I'm at a loss as to what setting is chopping off the payload and putting the editor into a state that the page has to be reloaded.  Any suggestions would be greatly appreciated.

1 answer

Please see this bug report - I hope the workaround on it will resolve the issue you are experiencing:

Pasting a large amount of text will disconnect Synchrony

Hey Ann,

The person who worked on my ticket with your Support team pointed to ticket but also acknowledged that I already had the Synchrony proxy enabled.  My issue still persists.

I ended up switching to Apache for our reverse proxy.

Dan

Ann Worley Atlassian Team May 15, 2017

Thanks for the follow-up, it's good to know. 

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Tuesday in Confluence

Introducing Praecipio Consulting, an Atlassian Solution Partner

Hey there Community!  My name is Vannya Vallejo, the Channel Communication Specialist at Atlassian and I want to help Atlassian users like you learn about our Solution Partners and how they c...

345 views 0 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you