Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Confluence Upgrade from 5.6 to 6.13 fails Edited

Hi,

I have upgraded confluence 5.6 to 6.13 and my 10 Users: Starter License is valid until 30. Jan 2020 (Invoice AT-XXXXX).

SEN-XXXXX

After the upgrade I get an HTTP Status 404 error and the log file reports that the license is not valid anymore.

I would appreciate any help.

Thanks a lot

- Michael

 

/var/atlassian/application-data/confluence/logs/atlassian-confluence.log | head -n 20
2019-10-11 17:32:32,824 INFO [localhost-startStop-1] [com.atlassian.confluence.lifecycle] contextInitialized Starting Confluence 6.13.0 [build 7901 based on commit hash 58be3fa11e9ad58113c0ea45e7063389a7c7d344] - synchrony version 2.1.0-master-e100417c
2019-10-11 17:32:36,279 INFO [localhost-startStop-1] [springframework.web.context.ContextLoader] initWebApplicationContext Root WebApplicationContext: initialization started
2019-10-11 17:32:39,691 INFO [localhost-startStop-1] [com.atlassian.confluence.lifecycle] <init> Loading EhCache cache manager
2019-10-11 17:32:58,301 INFO [localhost-startStop-1] [springframework.web.context.ContextLoader] initWebApplicationContext Root WebApplicationContext: initialization completed in 22022 ms
2019-10-11 17:32:58,350 ERROR [localhost-startStop-1] [impl.health.checks.LicenseValidationHealthCheck] doPerform License validation failed.
2019-10-11 17:33:31,065 ERROR [localhost-startStop-1] [confluence.impl.health.DefaultHealthCheckRunner] logEvent Confluence support and upgrades for your current license have expired.
2019-10-11 17:33:31,066 ERROR [localhost-startStop-1] [confluence.impl.health.DefaultHealthCheckRunner] logEvent You'll need to supply a valid license key. Confluence can't start without this.
If you have a new license, please enter it on this page (/fixonly/fixlicense.action) and restart.
2019-10-11 17:33:31,528 INFO [localhost-startStop-1] [atlassian.plugin.manager.DefaultPluginManager] earlyStartup Plugin system earlyStartup begun
2019-10-11 17:33:35,441 WARN [localhost-startStop-1] [org.twdata.pkgscanner.ExportPackageListBuilder] logDuplicateWarning Package Scanner found duplicates for package 'javax.annotation' with different versions. Files: javax.annotation-api-1.3.2.jar and jsr305-3.0.1.jar
'/opt/atlassian/confluence/confluence/WEB-INF/lib/javax.annotation-api-1.3.2.jar'
'/opt/atlassian/confluence/confluence/WEB-INF/lib/jsr305-3.0.1.jar'
2019-10-11 17:33:38,339 WARN [FelixStartLevel] [extender.internal.support.ExtenderConfiguration] addDefaultDependencyFactories Gemini Blueprint extensions bundle not present, annotation processing disabled.
2019-10-11 17:33:41,737 WARN [localhost-startStop-1] [jdbc.env.internal.JdbcEnvironmentInitiator] initiateService HHH000342: Could not obtain connection to query metadata : Unable to resolve name [com.atlassian.hibernate.dialect.HSQL2Dialect] as strategy [org.hibernate.dialect.Dialect]
2019-10-11 17:33:41,754 WARN [localhost-startStop-1] [confluence.impl.vcache.SynchronousExternalCache] lambda$get$11 Failed to read entry from cache 'com.atlassian.bandana.BandanaPersister': Failed due to UNCLASSIFIED_FAILURE
2019-10-11 17:33:41,938 WARN [localhost-startStop-1] [jdbc.env.internal.JdbcEnvironmentInitiator] initiateService HHH000342: Could not obtain connection to query metadata : Unable to resolve name [com.atlassian.hibernate.dialect.HSQL2Dialect] as strategy [org.hibernate.dialect.Dialect]
2019-10-11 17:33:41,944 ERROR [localhost-startStop-1] [atlassian.confluence.plugin.BandanaPluginStateStore] load Exception when loading plugins state from the database. Falling back to in memory state.

3 answers

1 accepted

0 votes
Answer accepted

What worked for me (update from 6.8.3 to 6.13.9):

The log states (the posted one too):

"If you have a new license, please enter it on this page (/<yourcontextpath>/fixonly/fixlicense.action) and restart."

If you use that URL, you get a box to drop your license key into and everything works fine.

Why confluence doesn't makes a re-direct for that is unknown to me.

this is wrong place to look for license related issues

contact Atlassian support.atlassian.com

0 votes
Petr Vaníček Community Leader Oct 13, 2019

Hi,

I just edited your question and removed your SEN ID. You need to contact Atlassian support directly as @jira guy said.

Maybe your problem is also in using HSQL DB - I really recommend you to switch regular DBMS like PostgreSQL because HSQL is not for production purposes and also it's not supported by Atlassian support.

So try switch to normal DBMS and then contact Atlassian support - there is KB article for how to switch to another DBMS - https://confluence.atlassian.com/doc/migrating-to-another-database-148867.html

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What do you think is the most *delightful* Confluence feature? Comment for a prize!

- Create your own custom emoji 🔥 - "Shake for Feedback" on mobile 📱 - An endless supply of GIFs via GIPHY 🤩 Is there anything quite as nice as a pleasant surprise? Comment below with what...

335 views 23 8
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you