Hi!
I try to install Confluence Server in Docker. I tried as official image and also unofficial one. Problem is the same - failure on database step.
Steps to reproduce:
* install container
* make port 8005 accessible outside the server nginx (I guess could be replaced to any other reverse-proxy server)
* Visit main page http://..../
* Choose Trial install
* Check Confluence QA and Calendar
* Enter Confluence trial license key
* Choose DB options: Direct JDBC, database credentials
* Press "Next"
* Pages starts to load, but process takes toooo long. Then HTTP timeout gets exhausted, so I see 504 error page.
* When I check database I can see tables created by confluence - so DB was well available to Confluence installer.
* Next I wait until CPU usage of Confluence container goes down.
* I try to reload the installation page in browser and get error (see below pls)
How can I install Confluence to Docker?
HTTP Status 500 - Unable to register MBean [com.atlassian.confluence.jmx.TaskQueueWrapper@1dc0b1c9] with key 'Confluence:name=MailTaskQueue'; nested exception is javax.management.InstanceAlreadyExistsException: Confluence:name=MailTaskQueue
type Exception report
message Unable to register MBean [com.atlassian.confluence.jmx.TaskQueueWrapper@1dc0b1c9] with key 'Confluence:name=MailTaskQueue'; nested exception is javax.management.InstanceAlreadyExistsException: Confluence:name=MailTaskQueue
description The server encountered an internal error that prevented it from fulfilling this request.
exception
com.atlassian.config.ConfigurationException: Unable to register MBean [com.atlassian.confluence.jmx.TaskQueueWrapper@1dc0b1c9] with key 'Confluence:name=MailTaskQueue'; nested exception is javax.management.InstanceAlreadyExistsException: Confluence:name=MailTaskQueue
com.atlassian.confluence.setup.actions.AbstractSetupAction.transitionFromColdToVacantState(AbstractSetupAction.java:161)
com.atlassian.confluence.setup.actions.SetupStandardDatabaseAction.setupDatabase(SetupStandardDatabaseAction.java:46)
com.atlassian.confluence.setup.actions.AbstractDatabaseCreationAction.execute(AbstractDatabaseCreationAction.java:36)
..... skipped .....
The full stack trace of the root cause is available in the Apache Tomcat/8.0.41 logs.