Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Confluence Server 7.0.3 hangs often (becomes unresponsive) after upgrade from version 6.15 Edited

Hello,

I have a plain vanilla Confluence Server installation on Debian. I have not installed any 3rd party plug-ins. I have about 5 spaces only and 3 users. The system used to work very well and very fast, AND very stable in version 6 but since upgrading to 7.0.3 I have stability problems. once or up to 3 times a day the server hangs and I need to systemctl restart confluence. Please help!

2 answers

Hi,

Your title 'memory leak' but You said 'server hangs'. Could You please clarify how You decide that 'memory leak'? Something in logs?

B.R.

Hi,

Sorry I was jumping the gun here  -  I am not sure what the cause is. The symptom is that the server hangs and the restart helps. What information do you need in order to narrow down possible causes?  Are there report of other users with that problem?

I am watching it for now

Hi,

Sorry for long time answer. I recommend analyze log files first, maybe some interesting find here. https://confluence.atlassian.com/doc/working-with-confluence-logs-108364721.html

Also try increase memory for jvm. I have case when new app use more memory and won't work with previous volume (but in that case app won't start). Anyway try increase memory. 

https://confluence.atlassian.com/doc/managing-application-server-memory-settings-32899336.html

If You have subscription also recommend send request to support team.

https://support.atlassian.com/contact/#/

For monitoring jvm memory usage https://community.atlassian.com/t5/Confluence-questions/How-to-monitor-Confluence-Heap-memory/qaq-p/1024637

B.R.

I have the exact same problem. Updated from 6.14.02 yesterday and confluence is locking up every few hours now. The logs say something about a possible memory leak, which is maybe where the OP got that from.

I looked through the logs and don't see any problems. We have many users and lots of plugins, so very different than op.

i see now that you have released 7.0.4 today (figures, i just upgraded yesterday) but the release notes are not available for it.

https://confluence.atlassian.com/doc/confluence-release-notes-327.html

can you point me to where those might be? its possible they have identified the issue already.

 

I will look at your post BR and see if i can find some more info this afternoon. I have already adjusted my memory limits higher years ago and the machine has 14gb of ram. When its locked up (unresponsive) its only using 50% of the available ram.

is it possible i have to update java on the server as well? or the confluence update has java. All my plugins are updated.

 

Oh and it should be mentioned i am on windows server 2016.

they now posted it.

https://confluence.atlassian.com/doc/issues-resolved-in-7-0-4-979415811.html

 

a bugfix release. I like the one that says it lags 30 seconds PER CLICK.. lol. i will apply this update tomorrow and see if it resolves the issue.

Like Andrew likes this

Thank you. I will also apply this now

UPDATE:  Problem is still there. Had to manually restart every couple of days or so. Now I am doing nightly restarts and this seems like a good workaround.

Hi,

I think it is not 'good' it is looks like more as 'last chance' :-) 

I'm glad if it work for You.

Just FYI:

Do You have support subscription in atlassian? Maybe they can help https://support.atlassian.com/contact/#/

I remember case problem with soft (no atlassian) where cause of the problem was in hardware-driver combination. To resolve we migrate soft to another hardware. 

B.R.

Hi Andrew, with "good" I meant good enough for me. It works and considering I have only a 10 user license I understand there is not much personal attention I can get from Atlassian directly. I trust that if it really is a memory leak that it will eventually get fixed. In the meantime, I might try one or the other Java VM tuning option.. but it's not high on my priority list while Confluence is working fine during daily operational hours.

My problem was solved with that update and never re-occured. I would check your logs

 

"C:\Program Files\Atlassian\Application Data\JIRA\log"

"C:\Program Files\Atlassian\JIRA\logs"

 

Check your memory limits in java and set them higher maybe? that solved some performance problems i was having when i was just starting with jira.

https://confluence.atlassian.com/adminjiraserver073/increasing-jira-application-memory-861253796.html

right now i am set at 1024 minimum and 4096 max in that java registry key. This works fine for about 30 agents and 150 staff. My memory use is at 77% right now (6.9gb out of 9gb) with jira taking about 3-4gb and sql server taking 1gb or so.

 

if i had more performance problems i would dump more ram at apache (java), and take a look at the logs. you probably have to diagnose the issue yourself.

are all your plugins updated?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What do you think is the most *delightful* Confluence feature? Comment for a prize!

- Create your own custom emoji 🔥 - "Shake for Feedback" on mobile 📱 - An endless supply of GIFs via GIPHY 🤩 Is there anything quite as nice as a pleasant surprise? Comment below with what...

494 views 24 9
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you