Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,293,760
Community Members
 
Community Events
165
Community Groups

Confluence PR_END_OF_FILE_ERROR

Hi,

 

I have installed Confluence on a Docker container with a Confluence server license. I have tried to renew the certificates with Let's Encrypt, but I get the following error when I am trying to access the Confluence page: PR_END_OF_FILE_ERROR.

I have generated the certificates using the following commands:

openssl pkcs12 -export -in cert.pem -inkey privkey.pem -out cert_and_key.p12 -name tomcat -CAfile chain.pem -caname root

keytool -importkeystore -destkeystore MyDSKeyStore.jks -srckeystore cert_and_key.p12 -srcstoretype PKCS12 -srcstorepass <password> -alias tomcat

keytool -import -trustcacerts -alias root -file chain.pem -keystore mykey.jks

Until 3 months this way was working fine.

Any idea of why it is not working?

1 answer

0 votes

Where did you get that error from?  I've seen it before when I've had problems using Firefox to connect to a https based service, but only coming from the browser.

The error from Firefox is not really very helpful, it's actually not reading a file that is chopped off before it ends, it's really reading a list of certificates and ciphers to find a pair that works with the service, not finding any, and then reaching the end of the list.  But it might not be just the list that Firefox is working through, there may be something else telling it that a valid cert/cipher pair is not valid.

Your setup commands look ok to me, I'd expect them to work, but I'd want to check that they are installing the right certificates in the right places in the right way.  Most importantly, which key store you have added them to - it needs to be the key store that the user account that is running Confluence uses, when running the Java virtual machine that Confluence runs in.

My usual mistake is to install certs in the system's install of Java, rather than the Java that Jira/Confluence/Bitbucket uses.

The other problems you might be having are:

  • Using a cipher Firefox is not familiar with (your commands do not do this, I've mentioned it for other people who might read this)
  • A proxy, VPN or load balancer between you and the server that might be making man-in-the-middle changes to the data stream
  • Anti virus software on either server or your machine can sometimes cause this message by breaking the connection from Firefox
  • Extensions or configurations can break Firefox's ciphers.

Could you try an "incognito" session in Firefox to rule most of those out?  Or better, try a different browser, ideally a recent version of a standards-compatible browser with clean install (no extensions or config tweaks - any of the big name browsers other than Internet Explorer)

Hi Nic,

Thanks for the reply. 

Indeed, just Firefox throws this error, others were showing ERR_CONNECTION_CLOSED. 

The problem was that I was generating the JKS on machine that had a different JAVA version than on the machine that hosts Confluence. 

Issue is solved now. 

Thank you,

Dan

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

Confluence: Where work and wellness meet

Feeling overwhelmed by the demands of work and life? With a 25% increase in the prevalence of anxiety and depression worldwide during the pandemic, for most of us, it’s a resounding yes . 🙋‍♀️ ...

763 views 5 21
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you