Confluence - Missing icons everywhere Edited

I tried to import a space from a backup and it failed because the hdd ran out of space. I then deleted the half imported spaced and did it again. This time it worked.

But since then all icons in Confluence are missing. Absolutely everything. Images which I inserted in pages load fine, but everything standard icon does not load.

Here is a screenshot:
https://www.dropbox.com/s/3xowt2amwg0iaox/confluence_missing_icons.png?dl=0

 

Tried this guide, but it didn't help.

https://confluence.atlassian.com/confkb/profile-picture-on-the-top-right-corner-is-missing-402030818.html

 

In the browser's developer console I see several errors:

Failed to load resource: the server responded with a status of 404 (Not Found) default-space-logo-256.png
Failed to load resource: the server responded with a status of 500 (Internal Server Error) add_profile_pic.png
Failed to load resource: the server responded with a status of 404 (Not Found) default.png

So basically 404 and 500 related to default images.

2 answers

0 vote
Maarten Cautreels Community Champion Apr 16, 2017

Hi Stefan,

As far as I can see, all images that are missing are user uploaded images (attachments and profile pictures). My suggestion would be to take a look at this kb-article to see if you can get your missing attachments back.

Another solution might be to trigger a reindex of all Confluence content. The import might have rendered the index to become invalid. Please take into account that a reindex might take a long time depending on the size of your instance!

Best,

Maarten

Hi Maarten, thanks for the hint. I'll take a look at these linked articles but I doubt they'll help.

Confluence does not even load standard icons like the plus and minus signs in a table. These are not ones I uploaded myself.

0 vote
Ann Worley Atlassian Team Apr 26, 2017

One of the images in the dev console output you included is "default-space-logo-256.png". I found that file on my instance under:

<Confluence_Install_dir>/confluence/images/logo/default-space-logo-256.png

Please make sure the missing images' files are present in the install directory and that the user running Confluence has file system permissions to access them.

Good idea and thanks for the hint. "Sadly" everything is fine and the files are there and accessible.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jul 10, 2018 in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

786 views 23 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you